App is still running after it is uninstalled (only if it's uninstalled while it's running)

RESOLVED WONTFIX

Status

Firefox Graveyard
Webapp Runtime
P2
normal
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

26 Branch

Details

(Reporter)

Description

4 years ago
STR
1. Go to http://mozqa.com/webapi-permissions-tests/
2. Install Poppit app from Hosted App Test Case 20.
3. Click on 'Install Package App' button.
4. Click Install.
5. Click Ok.
6. Run app.
7. Uninstall the app while the app is running.
7a. Windows
1. Go to Control Panel\All Control Panel Items\Programs and Features.
2. Uninstall the app.
7b. Linux
1. Open Terminal and write this line: '/home/user.account/.name of the app/webapprt-stub -remove'

Expected result:
A message is prompted saying that the app is still opened and cannot be uninstalled.

Actual result:
The app can be used even though is uninstalled. 

Note:
This issue is Windows and Linux only, on Mac OS X this does not happen on latest Aurora (you cannot move the app to trash when it's opened).

Updated

4 years ago
status-firefox26: --- → ?
Priority: -- → P2
Summary: App is still running after it is uninstalled → App is still running after it is uninstalled (only if it's uninstalled while it's running)
I think this is the expected behavior on Linux, you can uninstall applications while they're running and they are uninstalled cleanly (so you can't execute them again).
In my opinion this isn't a problem on Windows too.
The app is cleanly uninstalled and, if it is running, once it's closed it can't be executed again.
Flags: needinfo?(bwalker)
Flags: needinfo?(bwalker)
Marco is saying that uninstalling running apps is allowed in Windows and Linux, which I think means we would mark this bug as INVALID?
Maybe, but I'd like to double-check with tabraldes, since rstrong added code that prevents Firefox's uninstaller from doing this over in bug 396870, so there might be some non-obvious reason why it's a bad idea on Windows.

cc:ing tabraldes for his thoughts!
Erm, actually I'll needinfo him!
Flags: needinfo?(tabraldes)
On Linux, an app gets loaded into memory and after that the OS doesn't care what hapens to the file on disk, so removing a running application is easy.

On Windows, the OS prevents you from deleting an exectuable file while it is still running. You CAN, however, move/rename EXEs that are currently executing. The WebappRT app uninstaller takes advantage of that fact [1], and is specifically written to allow uninstalling apps that are in use.

In both these cases, we will run into trouble if the running application needs to access other files that may have been removed. My suggestion is this: If running apps continue functioning normally even if they have been uninstalled, we should just allow uninstallation while they are running. If some apps break after being uninstalled, we should prevent uninstallation while the app is running.

[1] https://mxr.mozilla.org/mozilla-central/source/webapprt/win/webapp-uninstaller.nsi.in?rev=fb30db0fa0aa#79
Flags: needinfo?(tabraldes)
Blocks: 1111077
Per bug 1238079, we're going to disable the desktop web runtime and remove it from the codebase, so we won't fix these bugs in it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.