'Save Attachment' dialogs title located in msgbase.dll

VERIFIED FIXED in mozilla1.2alpha

Status

P2
normal
VERIFIED FIXED
18 years ago
11 years ago

People

(Reporter: annac, Assigned: ssu0262)

Tracking

({l12y})

Trunk
mozilla1.2alpha
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Selecting 'Save As' for a received attachment in mail opens a dialog titled
'Save Attachment'. This title text appears to be coming from msgbase.dll and is
therefore unlocalisable. 


Steps to Repro.
1.  Launch mail and setup a valid account
2.  Send this account a mail including an attachment
3 [details] [diff] [review].  Right click on the received mail and select 'Save As'
(Reporter)

Updated

18 years ago
Keywords: l12y

Comment 1

18 years ago
/mailnews/base/src/nsMessenger.cpp, line 395 --
NS_NAMED_LITERAL_STRING(saveAttachmentTag, "Save Attachment");
/mailnews/base/src/nsMessenger.cpp, line 685 --
GetString(NS_ConvertASCIItoUCS2("Save Attachment").get()),
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
assigning to putterman, cc mscott,yokoyama
Assignee: yokoyama → putterman

Updated

18 years ago
Keywords: nsBranch
MScott is this one gonna be fixed any time soon (i.e. TM0.9.4)?

Comment 4

18 years ago
Marking nsbranch- as it was decided in the August bug triage that we wouldn't
have enough time in eMojo to fix this.  Let's revisit for MachV.
Keywords: nsbranch-

Comment 5

18 years ago
removed keyword nsbranch since bug now has nsbranch-, per pdt mtg.
Keywords: nsbranch

Comment 6

18 years ago
reassigning to ssu
Assignee: putterman → ssu

Updated

18 years ago
Blocks: 107067

Updated

18 years ago
Keywords: nsbranch-

Comment 7

18 years ago
Nominating for nsbeta1.
Keywords: nsbeta1

Updated

18 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 8

18 years ago
*** Bug 108602 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
need to do "Save All Attachments" as well.
Summary: 'Save Attchment' dialog title located in msgbase.dll → 'Save Attachment' dialogs title located in msgbase.dll

Updated

18 years ago
Priority: -- → P3

Updated

18 years ago
Target Milestone: --- → mozilla0.9.9

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2

Updated

17 years ago
No longer blocks: 107067

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Updated

17 years ago
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2

Comment 10

17 years ago
Both "Save attachment" and "Save all attachments" are hardcoded in:
mailnews/base/src/nsMessenger.cpp

ji, is this for Windows only? Looks Mac has same problem...

Comment 11

17 years ago
This problem exists for all the platforms. 
Hardware: PC → All

Comment 12

17 years ago
Created attachment 71949 [details] [diff] [review]
use StringBundle to retrieve texts in messenger.properties

sean: Attached should fix your problem.
(Assignee)

Updated

17 years ago
Keywords: patch

Comment 13

17 years ago
Michele, since this has a patch already, should we mark this as nsbeta1+? This 
is kind of critical for l10n.
(Assignee)

Comment 14

17 years ago
Comment on attachment 71949 [details] [diff] [review]
use StringBundle to retrieve texts in messenger.properties

thanks for the patch Roy.
r=ssu

looking for sr= now.
Attachment #71949 - Flags: review+

Comment 15

17 years ago
Comment on attachment 71949 [details] [diff] [review]
use StringBundle to retrieve texts in messenger.properties

sr=mscott
Attachment #71949 - Flags: superreview+

Comment 16

17 years ago
marked nsbeta1+
Keywords: nsbeta1- → nsbeta1+
Comment on attachment 71949 [details] [diff] [review]
use StringBundle to retrieve texts in messenger.properties

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #71949 - Flags: approval+
(Assignee)

Comment 18

17 years ago
roy's patch checked in to trunk only.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 19

17 years ago
ji, you can verify this bug now. I just tested 02-03-07 trunk, by modifying the 
file in language pack, "Save attachment" and "Save all attachment" can be 
easily localized like Japanese.

Comment 20

17 years ago
Marked it as verified. Ying, thanks for the help.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.