Closed Bug 931082 Opened 6 years ago Closed 6 years ago

LayerActivityTracker shouldn't force invalidate

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 911889
blocking-b2g 1.3+

People

(Reporter: BenWa, Assigned: BenWa)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
This gets in the way of pre-rendering the homescreen and could burn us in general.
Attachment #822424 - Flags: review?(roc)
blocking-b2g: --- → koi?
Backed out for test failures. Roc thinks his patch queue will fix this while avoiding this failure. Hopefully we can uplift this patch to aurora for koi.
this issue blocks 920921, according to triage result, mark it koi+
blocking-b2g: koi? → koi+
Is this a flatfish only bug due to 920921 or will this landing have a noticeable impact on the phone ?
This is a platform bug we have everywhere. But I wouldn't say it would have a noticeable impact on devices other then the flatfish and maybe fennec on tablets.
Blocks: 935345
1.3+ based on comment 5.
blocking-b2g: koi+ → 1.3+
Roc, you said your patch queue would cover this. What bug(s) is that?
Flags: needinfo?(roc)
Bug 911889, which already landed. The relevant change is here: http://mxr.mozilla.org/mozilla-central/source/layout/base/ActiveLayerTracker.cpp#84

Please check if this is fixed for you and if it is, close the bug.
Flags: needinfo?(roc)
Looks to be working. Since flatflish is 1.3 I believe we don't need to uplift anything.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911889
You need to log in before you can comment on or make changes to this bug.