[B2G][1.2][l10n][Gallery] Nederlands: The string Set as wallpaper is truncated

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

({l12y})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.2 affected, b2g-v1.4 affected, b2g-v2.0 affected)

Details

(Whiteboard: LocRun1.2)

Attachments

(1 attachment)

Created attachment 822495 [details]
2013-10-25-12-09-51.png

Description:
"Set as wallpaper" is truncated in the button when a picture is selected to add as a wallpaper.

Repro Steps:
1)  Updated Buri to Build ID: 20131025004000
2)  Tap on "Gallery".
3)  Tap on a picture.
4)  Tap on the "Share" icon.
5)  Tap on "Wallpaper".

Actual:
The string "Set as wallpaper" is truncated.

Expected:
The string is not truncated.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131025004000
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5eabd267ef04
Gaia: 606517ceafe0950c2b89822d5f13353743334f2c
Platform Version: 26.0a2
RIL Version: 01.02.00.019.082 

Notes:
Repro frequency: 100%
See attached: screenshot

Updated

5 years ago
Assignee: nobody → dutch.nl
Component: Gaia::Gallery → nl / Dutch
Product: Firefox OS → Mozilla Localizations

Comment 1

5 years ago
Can’t find a way of shortening this. As this is a developer's issue (…assuming 'set as' is only 6 characters wide for any language…), it needs a UX solution, e.g. by moving the button divider to the left (dynamically), or just creating two buttons on top of instead of next to each other, like elsewhere.
just a thought. as you are allready in the background setting is it not clear enough to use only 'instellen' and then we open a bug to change it in en-us also.
Fixed, verified on a flame, software 2.2 build 20140927040203
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 4

4 years ago
Please don't close Gaia bugs when
- the software version you are using is different from the version the bug was reported for
- your device is different than the one the bug was reported for, as well as the behaviour may or may not occur on various devices
- a string was changed, but the original problem persists (hence it is a UX issue, even when the bug wasn't set as such (yet))

I'd also appreciate it if you talk Gaia string issues over on irc if possible.

In this case, there is no fix involved and the problem is still valid on 1.2 and probably on any device.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Ton from comment #4)
> - the software version you are using is different from the version the bug
> was reported for
> - your device is different than the one the bug was reported for, as well as
> the behaviour may or may not occur on various devices

I haven't tested it with Dutch, but this should be fixed on 2.1 and 2.2 (see bug 841366).

If we don't close bugs because they're still valid on old versions (e.g. 1.2), we're never going to close them and the number of open bugs won't reflect the actual status of the localization.

Comment 6

4 years ago
(In reply to Francesco Lodolo [:flod] from comment #5)

> If we don't close bugs because they're still valid on old versions (e.g.
> 1.2), we're never going to close them and the number of open bugs won't
> reflect the actual status of the localization.

I know, and it would make it easier to close bugs allright. Yet I’d expect to see changed afected version info for the bug though, or comments like "closing (wfm) as this version is obsolete" in order to keep clear what versions were / are still affected.
(In reply to Francesco Lodolo [:flod] from comment #5)

> If we don't close bugs because they're still valid on old versions (e.g.
> 1.2), we're never going to close them and the number of open bugs won't
> reflect the actual status of the localization.

Agree.

I wonder, on which version is there still active ux development ( I tought the ux changes are closed in 1.2 and 1.3)? Because having ux bugs in the dutch component on versions who are not developed anymore is usesless.
open or close?

Comment 9

4 years ago
(In reply to Tim Maks van den Broek [:mad_maks] from comment #7)
> 
> I wonder, on which version is there still active ux development ( I tought
> the ux changes are closed in 1.2 and 1.3)? Because having ux bugs in the
> dutch component on versions who are not developed anymore is usesless.

Same question here. As this affects v1.2-2.0 and was solved in 2.1+, we could fix it for 2.0, but does it make sense to do so for 1.4 and below?
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
Just my 2 cents: there are quite a few examples recently where partners are still shipping on 1.3 or 1.4, for example. So I would say it makes sense to correct major issues in past versions

Comment 11

4 years ago
Thanks. Any idea if they'd be implemented for end user builds though, i.o.w. do all of them get updates, does it depend on manufacturers/partners etc.?

Comment 12

3 years ago
We've stopped shipping Firefox OS for phones. Thus resolving this as WONTFIX.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.