[PP] Mac Commercial crashes when starting Messenger

VERIFIED DUPLICATE of bug 9288

Status

()

P3
critical
VERIFIED DUPLICATE of bug 9288
20 years ago
22 days ago

People

(Reporter: pmock, Assigned: karnaze)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Build:
  Mac June 6 Commerical build (1999-07-06-10) installed on PPC 9600/300 and PPC
8500/300 running Mac OS 8.5.1

Problem:
  In the Commercial build, you crash when you try to start Messenger.  I'm
starting up Apprunner to the browser then clicking on the Messenger icon off the
component bar.  The browser start up ok.

Note: this problem does not occur on the today Mozilla build (1999-07-06-10)

Steps to reproduce problem:
0) Delete the Mozilla Registry Pref
1) Download today Commercial build, file ->  netscape5-mac-M8.sea.bin
   ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-07-06-10-M8/
2) Install today Commercial build
3) Run Apprunner
4) Go through the profile wizard
   Note: you will need to resize the window to refresh the dialog
5) From the browser window, click on the messenger icon from the component bar
   (The Task menu option "Messenger" appears to be broken)
   The Messenger window will start to draw then crash to Macsbug.

Macsbug
-------
 The “apprunner” heap at 07604720 is ok
 Totaling the “apprunner” heap at 07604720
                                 Total Blocks    Total of Block Sizes
  Free                           006C     #108   00291C40     #2694208
  Nonrelocatable                 00F8     #248   006E646C     #7234668
  Relocatable                    01B0     #432   0001A610      #108048
    Locked                       0005       #5   0000C3D0       #50128
    Purgeable and not locked     0000       #0   00000000           #0
  Heap size                      0314     #788   009926BC    #10036924
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  17EA82D0
  07FE2C80    PPC  17EA7604  main+00CF0
  07FE2A70    PPC  17C7518C  nsAppShellService::Run()+00018
  07FE2A30    PPC  17B93828  nsAppShell::Run()+00038
  07FE29B0    PPC  17B9412C  nsMacMessagePump::DoMessagePump()+0003C
  07FE2960    PPC  17B943E4  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00158
  07FE2910    PPC  17DF2FA8  Repeater::DoRepeaters(const EventRecord&)+00030
  07FE28D0    PPC  17DF2AC8  TimerPeriodical::RepeatAction(const EventRecord&)+
00048
  07FE2880    PPC  17DF2624  TimerImpl::Fire()+00024
  07FE2840    PPC  17DD730C  nsNetlibService::NetPollSocketsCallback(nsITimer*,
void*)+0001C
  07FE2800    PPC  17DB6DF4  NET_PollSockets+0002C
  07FE27B0    PPC  17DB2728  NET_ProcessNet+003C4
  07FE2420    PPC  17DBF720  net_ProcessFile+000DC
  07FE23D0    PPC  17DBEDF4  net_read_file_chunk+00258
  07FE2380    PPC  17DDB06C  stub_put_block(_NET_StreamClass*, const char*,
long)+00080
  07FE2330    PPC  17987E44  nsDocumentBindInfo::OnDataAvailable(nsIURI*,
nsIInputStream*, un
signed int)+00074
  07FE22E0    PPC  17AC49F8  nsParser::OnDataAvailable(nsIURI*, nsIInputStream*,
unsigned int
)+001A8
  07FE2280    PPC  17AC4418  nsParser::ResumeParse(nsIDTD*)+00098
  07FE2230    PPC  17AC456C  nsParser::BuildModel()+00070
  07FE21E0    PPC  17AB2090  CNavDTD::BuildModel(nsIParser*, nsITokenizer*,
nsITokenObserver*
, nsIContentSink*)+0009C
  07FE2180    PPC  17AB2698  CNavDTD::HandleToken(CToken*, nsIParser*)+0025C
  07FE2120    PPC  17AC25CC  CTokenHandler::operator()(CToken*, nsIDTD*)+0002C
  07FE20E0    PPC  17AB13A8  NavDispatchTokenHandler(CToken*, nsIDTD*)+00074
  07FE2090    PPC  17AB452C  CNavDTD::HandleEndToken(CToken*)+001BC
  07FE1F90    PPC  17AB6968  CNavDTD::CloseContainersTo(nsHTMLTag, int)+00044
  07FE1F30    PPC  17AB6874  CNavDTD::CloseContainersTo(int, nsHTMLTag, int)+
000B0
  07FE1DB0    PPC  17AB6704  CNavDTD::CloseContainer(const nsIParserNode&,
nsHTMLTag, int)+00
160
  07FE1D50    PPC  17AB629C  CNavDTD::CloseFrameset(const nsIParserNode&)+00028
  07FE1D00    PPC  176AA14C  HTMLContentSink::CloseFrameset(const nsIParserNode&
)+00050
  07FE1CB0    PPC  176AA80C  HTMLContentSink::StartLayout()+0017C
  07FE1BA0    PPC  1768CDD0  PresShell::InitialReflow(int, int)+00204
  07FE1930    PPC  178B83A4  ViewportFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+00290
  07FE17B0    PPC  17676BE8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  07FE1750    PPC  17720648  RootFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const n
sHTMLReflowState&, unsigned int&)+00268
  07FE1580    PPC  17676BE8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  07FE1520    PPC  1789F080  nsAreaFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const
 nsHTMLReflowState&, unsigned int&)+000C8
  07FE14A0    PPC  17830CD8  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+001F4
  07FE08C0    PPC  178319F0  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00064
  07FE0840    PPC  17831E44  nsBlockFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int*)+
000BC
  07FE07F0    PPC  17833228  nsBlockFrame::ReflowInlineFrames(nsBlockReflowState&
, nsLineBox*
, int*)+00134
  07FE0770    PPC  17833478  nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&,
nsLineBox*,
 nsIFrame*, unsigned char*)+00040
  07FE0700    PPC  17839A38  nsLineLayout::ReflowFrame(nsIFrame*, nsIFrame**,
unsigned int&)+
00318
  07FE0590    PPC  17828318  nsHTMLFramesetFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics
&, const nsHTMLReflowState&, unsigned int&)+00C00
  07FE03F0    PPC  17826F8C  nsHTMLFramesetFrame::ReflowPlaceChild(nsIFrame*,
nsIPresContext&
, const nsHTMLReflowState&, nsPoint&, nsSize&, nsPoint*)+00308
  07FE02A0    PPC  17676BE8  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  07FE0240    PPC  178279F4  nsHTMLFramesetFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics
&, const nsHTMLReflowState&, unsigned int&)+002DC
 Closing log

Updated

20 years ago
Severity: major → critical
Target Milestone: M8

Comment 1

20 years ago
changing severity to critical since we're supposed to release the commerical
builds for the seamonkey milestone M8.

Set target milestone to M8.

Comment 2

20 years ago
cc: cyeh.  Perhaps this is a release/build problem?

Comment 3

20 years ago
it's possible that it might be build related. i'll do digging. the other thing to
note is that spell-checker is included in the commercial builds, and not in the
mozilla build.  also, if someone can get this to crash, I'd like to be able to
look at it in macsbug.

Comment 4

20 years ago
pls see pmock or nbaca (bldg 21, 3rd fl) - they're both able to crash.

Updated

20 years ago
Status: NEW → ASSIGNED
I will try to reproduce the problem on my Mac and see what append.

Updated

20 years ago
Assignee: ducarroz → karnaze
Status: ASSIGNED → NEW
Component: Back End → HTMLFrames
Product: MailNews → Browser
I was able to reproduce the crash with today commercial build and with a mozilla debug build pulled arround noon

today (after Yatt checkins) when opening the addressbook.  I crash only when I try to open a xul file that use <

html:iframe>. If you remove the iframe tag from messenger.xul then you would crash. The problem may be in relation

with the fact that new windows have a very small size. I any case, I don't thing it has anything to do with mailnews,

therfore I reassign the bug to browser folk.

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 9288 ***
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

20 years ago
Verified as a duplicate of bug 9288.

In bug 9288, I followed Paul Hangas steps to reproduce problem. I passed the
apprunner -mail parameter.  Comparing the Macsbug log produce, it crashes with
the same call.

Updated

24 days ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.