mail attachments fail to open using appropriate actions

VERIFIED WORKSFORME

Status

MailNews Core
MIME
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: David, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hi,

Several times I have been sent attachments of known file types (html, for
example), and when I went to open the attachment it didnt give me the option of
openning the attachment in the browser.  Instead, the standard option was to
save the file, even though it recognised the file (as text/html in the most
recent case).  When I went to define an action for this file type, it said there
was already one defined.

Comment 1

17 years ago
Looks very similar to what i see:
not all but some attachments are not handled correctly. In some
cases, those attachments are from previous mail with attachments
and that have been forwarded. The attachment is then seen as a
plain text attachment (when saving the attachment and applying the
'file' command on the saved file, the result is 'Ascii Text').

In some other cases, the attachment is seen as a Transport Neutral
Encapsulation Format, which looks to be a Windows stuff containing
some header and the real attached file (binary).

For example, in the first case, here is the header of one of them:

-------- example ----------------

Date: Thu, 16 Aug 2001 04:16:19 -0400
From: "Caroline.Bicking@daimlerchrysler.com" <Caroline.Bicking@daimlerchrysler.c
om>
To: cpanzini@lear.com,dperes@lear.com, GBerthon@lear.com,
        gduarte@lear.com, JIroudayassamy@lear.com, lcarreira@lear.com,
        lperez05@lear.com, SRayah@lear.com, vdacruz@lear.com,
        michele.bicking@scicdeveloppement.fr
Subject: Tr: Fw: hello
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="=_2C7661DA.66072F44"

--=_2C7661DA.66072F44
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline





--=_2C7661DA.66072F44
Content-Type: video/mpeg
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="chinspt.mpg"

AAABui//+f1xgAkXAAABuwAMgAkXB6H/wMAg4OAuAAABwAC+QCAv//30///9MsAyIyQhERJIAAAA
AKosG6s0025143637258524039311d3bbbbb5bHzWta1rXd22222+Wx81rWta14VpN1KdXHaZmRp
2qEDlksb0UbzZZZ0xwnvkbbLY9cUa5g2tZLJOvRnMPlr2DYrLXCETQbkcD1UIllOuRrbukkhGVUE
hWnJNEtW4aOQxlKo20AW0uoNEULcUml1FeDXO


--------------- end of example ----------------------

Comment 2

17 years ago
I am using build 2001083003 on WinNT

Opening attachments by double-clicking or righ-clicking and selecting open is
not working(assuming an action has already been defined). If I remember right
the daily build before my current build was still working properly. So somehow
it was broken and I think many people would like to get this fixed asap.

I checked my temporary directory and I saw that mozilla was able to 'extract'
the attachment but somehow was unable to 'execute the defined action' like open
file using whatever appropriate application.

Comment 3

16 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Really WFM (not just batch), per ksosez.

Updated

16 years ago
QA Contact: esther → trix

Comment 5

16 years ago
works for me using 20020114
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.