Addon icons disappear randomly

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Rainer Brinkmann, Unassigned)

Tracking

24 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 822731 [details]
grey hachure on icons in bar adjusting mode

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

I noticed this bugs for a couple of past FF versions. Unfortunately, there is no way to reproduce this bug, for it happens randomly, affecting sometimes the nav bar items only, sometimes the addon bar only, sometimes both. This effect seems independent of the type and number of addons installed.


Actual results:

A random number of icons in the bars disappear at a random intervall, or they're reordered or cannot be reordered in the order I put them on the bar (for a grey hachure is laid over the icons when in bar adjusting mode, cf. image). The intervall may be a couple of weeks or the next day.


Expected results:

Addon icons should stay where I put them on the bars unless I remove an addon. And icons should be allowed to be placed in a user-defined order unless the belong to a single addon (cf. the weather forecast icons in the image).
(Reporter)

Comment 1

5 years ago
Please contact me via e-mail if in need for more details.
Component: Untriaged → Toolbars and Customization
Keywords: arch

Comment 2

5 years ago
It could be a dupe of bug 575500.

Anyway, as you have many add-ons, maybe one if them triggers this issue?
Keywords: arch

Comment 3

4 years ago
This is still happening in Firefox 31.0.

This can be reproduced by restricting the network connectivity of Firefox using the Windows Firewall details are in bug 627224 https://bugzilla.mozilla.org/show_bug.cgi?id=627224.
(Reporter)

Comment 4

4 years ago
(In reply to 715ff9c6 from comment #3)
> This is still happening in Firefox 31.0.
> 
> This can be reproduced by restricting the network connectivity of Firefox
> using the Windows Firewall details are in bug 627224
> https://bugzilla.mozilla.org/show_bug.cgi?id=627224.

I'm the thread starter and cannot reproduce the bug so far on FF 31.0 on a Windows 8.1 Pro system with latest updates for OS and FF addons.

One reason might be my removal of the 'Forecastfox Weather' addon when updating to FF 31.0. With the latest FF update, all icons stay where I put them. Moreover, I don't use the 'The Addon Bar (Restored)' addon in order to being able to use the weather addon again.

Another reason might be that all 54 addons I currently use are fully compatible with FF 31.0, meaning that they no longer use the old style in developing addons (overlay), with some of them also being installable without relaunching FF.

Comment 5

4 years ago
715ff9c6@opayq.com, as the user doesn't use the same machine and environment, file a new bug instead of replying in old bugs, thank you.

And I close this bug as WORKSFORME as the OP are not able to reproduce it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.