If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

incorrect pasting of passwords from KeePassDroid

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: dmdsubs, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Opened KeePassDroid (v1.99.10); opened Firefox and visited a web site, e.g. http://www.zotero.org/, selected login; copied my username from KeePassDroid and pasted it into the applicable field; copied my password from KeePassDroid and pasted it into the applicable field.


Actual results:

I was not logged into Zotero.  When my password was 20 characters, a message was displayed stating the password was longer than 32 characters.

(I experienced similar problems with other sites, e.g. Ubuntu One, https://one.ubuntu.com/)


Expected results:

I should have been logged into Zotero.

Following the same steps but using Chrome instead of Firefox I was logged into Zotero; typing the password manually logged me into Zotero.  Accessing the same file as KeePassDroid from my (Windows 7) desktop using KeePass v1.26 and following the same steps (Firefox 24) logged me into Zotero.

Removing the characters '[' and '_' from a password enabled logging on but only when the password was less than 20 characters (a password with less than 20 characters but including, '[' or '_' for example, did not work).

Updated

4 years ago
Component: General → General
Product: Firefox for Android → Firefox
Version: Firefox 24 → 24 Branch
(Reporter)

Comment 1

4 years ago
I am new to submitting bugs and do not understand why the product was changed from Firefox for Android to Firefox.

The problem is with Firefox for Android but I submitted the bug using Firefox on a Windows 7 desktop.
Mis-read.
Component: General → General
Product: Firefox → Firefox for Android
Version: 24 Branch → Firefox 24
I'll look into this exact STR. I generally have not had problems with using KeepassDroid but I only use super long passwords for really important things.
Flags: needinfo?(kbrosnan)
Works for me using LDAP Persona sign in and a password with the requirements from comment 0 w/ the same version of KeePass from comment 0.
Flags: needinfo?(kbrosnan)
(Reporter)

Comment 5

4 years ago
I followed the steps in my original posting - except that I used Firefox 25.0.1 - and all worked fine.  I also tested other web sites (with different passwords) and experienced no problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(kbrosnan)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.