Show remaining days of an app to be reviewed on new version of apps

VERIFIED FIXED in 2014-02-18

Status

Marketplace
Developer Pages
P3
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Aaron Cajes, Assigned: mat)

Tracking

2014-02-18
Points:
---

Details

(Whiteboard: [incorrect_implementation])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

Upload a new version of an app in the Marketplace


Actual results:

It just displays the status and the submission date of my app


Expected results:

It should also displays the pending days before my app will be reviewed by a reviewer, just like when you submit a fresh app on the Marketplace.
(Reporter)

Comment 1

5 years ago
Created attachment 822782 [details]
Screen Shot 2013-10-27 at 12.39.04 AM.png

For reference. For now, it doesn't show the remaining days before an app gets reviewed on app upgrades.
(Reporter)

Updated

5 years ago
Summary: Show remaining days of an app to be reviewed → Show remaining days of an app to be reviewed on new version of apps
If the app is pending and it has a pending version, we show the "queue position":

http://cl.ly/image/281u30351O3F

For pending versions of already public apps (i.e., packaged apps), the "queue position" isn't shown. That's the bug.
Status: UNCONFIRMED → NEW
Component: General → Developer Pages
Ever confirmed: true
Priority: -- → P3
(Reporter)

Comment 3

5 years ago
Yep. Exactly.
(Assignee)

Updated

5 years ago
Assignee: nobody → mpillard
(Assignee)

Updated

4 years ago
Duplicate of this bug: 951220
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 952772
(Assignee)

Comment 6

4 years ago
Fixed in https://github.com/mozilla/zamboni/commit/7f05657340c47bbc0e0ef49ac69c4be587ae2542

STR:
- Submit a packaged app, set content ratings etc
- Verify that it says in the submission list and in the app edit status page how much time the app is expected to wait in the queue / what is its position in the queue
- Review that app, push it to public
- Submit a new version
- Verify that it says in the submission list and in the app edit status page how much time the latest version is expected to wait in the queue / what is its position in the queue
- Push that version to public in reviewer tools
- Make sure the status page and submission list in devhub only say the app is public now
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-02-18

Comment 7

4 years ago
Verified as fixed in https://marketplace-dev.allizom.org/developers/ on FF30 (Win 7).
Postfix screencast http://screencast.com/t/dGs8SxXprR
Closing bug.
Status: RESOLVED → VERIFIED

Updated

4 years ago
Whiteboard: [incorrect_implementation]
You need to log in before you can comment on or make changes to this bug.