Need ability to re-detect proxy without restarting Firefox

RESOLVED DUPLICATE of bug 1245210

Status

()

RESOLVED DUPLICATE of bug 1245210
5 years ago
3 years ago

People

(Reporter: abcdzywx, Unassigned)

Tracking

24 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Switch computer networks between one that uses a proxy and one that doesn't.  For example, connect to or drop connection from a VPN, where the VPN network requires a proxy and the proxy is automatically detected.


Actual results:

Firefox cannot re-detect the proxy settings without being completely closed and restarted.  If started on the network with the proxy and switched to the network without the proxy, Firefox will error that the proxy server is not available.  If started on the network without the proxy and switched to the network with the proxy, Firefox will error on an invalid connection.

It is possible to change the proxy settings during the session from automatically-detected to manual, but there does not seem to be any way to trigger Firefox to re-detect the proxy using the automatic settings.


Expected results:

There should be some way to make Firefox re-detect proxy settings in the middle of while the program is running.  This does not necessarily need to be an automatic re-detection; there should at least be a manual "re-detect" option, and it should be convenient to the user.  For example, the user would connect to or drop from VPN and then need some quick way to reload proxy settings.  Having to restart the whole application is very cumbersome and annoying.

Updated

5 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
dup?
Flags: needinfo?(daniel)
Whiteboard: [necko-backlog]
This described functionality is now what is being done automatically on network change events, which could make this a RESOLVED/FIXED, but then we have an issue with the automatic using of a proxy when coming back to a network with one so I'll make this a dup of that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(daniel)
Resolution: --- → DUPLICATE
Duplicate of bug: 1245210
You need to log in before you can comment on or make changes to this bug.