arrow + gutter looks crappy on dark theme

RESOLVED DUPLICATE of bug 943883

Status

RESOLVED DUPLICATE of bug 943883
5 years ago
2 months ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Created attachment 822910 [details]
Screen Shot 2013-10-27 at 7.33.24 AM.png

The arrow is light, while the gutter is dark. Looks way off. IMO, the gutter looks a little off in general.
(In reply to Nick Fitzgerald [:fitzgen] from comment #0)
> Created attachment 822910 [details]
> Screen Shot 2013-10-27 at 7.33.24 AM.png
> 
> The arrow is light, while the gutter is dark. Looks way off. IMO, the gutter
> looks a little off in general.

Any suggestions?  I think maybe if we just made the arrow a little darker it would smooth things over.  The gutter color isn't that far off from the screens from shorlander that you can see here: https://bugzilla.mozilla.org/show_bug.cgi?id=930588#c4, but maybe we could lighten the gutter up a bit (it's just using the .theme-bg-darker color right now).
How about just using a black arrow?
1. The arrow should definitely match the gutter color, whatever the gutter color is.

2. Something about the gutter just looks off. I think we need more contrast between the gutter and the text area. The high contrast border on the gutter combined with the low contrast between the gutter and the text area makes it especially weird, IMO.
(In reply to Nick Fitzgerald [:fitzgen] from comment #3)

> 2. Something about the gutter just looks off. I think we need more contrast
> between the gutter and the text area. The high contrast border on the gutter
> combined with the low contrast between the gutter and the text area makes it
> especially weird, IMO.

Is this at least partially resolved by Bug 930588?  I think the high contrast border has been addressed, as can be seen in https://bugzilla.mozilla.org/attachment.cgi?id=822753&action=edit.  Also worth noting that we have requested updated designs for the editor light and dark theme.
Created attachment 823539 [details]
debugger-scrollable.png

One issue with just taking the arrow and making it black is that when the sources list is scrollable, the scrollbar is white (at least on OSX).  This would look weird if the arrow was black in this case.
Did you make it so that scroll bars are always visible? OSX only shows a gray scroll bar on top of the content when I scroll, for me.
(In reply to Brian Grinstead [:bgrins] from comment #4)
> (In reply to Nick Fitzgerald [:fitzgen] from comment #3)
> 
> > 2. Something about the gutter just looks off. I think we need more contrast
> > between the gutter and the text area. The high contrast border on the gutter
> > combined with the low contrast between the gutter and the text area makes it
> > especially weird, IMO.
> 
> Is this at least partially resolved by Bug 930588?  I think the high
> contrast border has been addressed, as can be seen in
> https://bugzilla.mozilla.org/attachment.cgi?id=822753&action=edit.  Also
> worth noting that we have requested updated designs for the editor light and
> dark theme.

This is definitely better, but yeah I think we should get more feedback from darrin/shorlander.
Created attachment 823602 [details]
screen shot with scrollbar

(In reply to Nick Fitzgerald [:fitzgen] from comment #6)
> Did you make it so that scroll bars are always visible? OSX only shows a
> gray scroll bar on top of the content when I scroll, for me.

Screen shot of this on my machine.
Welp, I guess osx's screen shot thing doesn't include those scroll bars...
(In reply to Nick Fitzgerald [:fitzgen] from comment #6)
> Did you make it so that scroll bars are always visible? OSX only shows a
> gray scroll bar on top of the content when I scroll, for me.

I see full scrollbars like bgrins when OS X is set to show either "Always" or "Automatically based on mouse or trackpad" and I am using an external mouse.  The thin overlay scrollbars that fitzgen sees are shown if you choose "When scrolling" or "Automatically based on mouse or trackpad" and no external mouse is connected.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 943883

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.