forms without enctype are submitted multiple times[form sub]

VERIFIED WORKSFORME

Status

()

Core
HTML: Form Submission
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Thomas Swan, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Submission of a one element form where form doesn't have enctype specified
results in multiple submissions to the same URL.  Specifying
enctype="multipart/formdata" fixed the problem.

I'm working on a small test case /* time constraints :-( */.  

Currently, I have this happening on an internal project and haven't developed a
small test case to repeat the problem.
Reporter, are you still seeing this?  Any luck with that testcase?

I've tried a few small cases, but I can't reproduce this.
(Reporter)

Comment 2

17 years ago
In all honesty, that project fell to the back burner for a while and I haven't
had to fool with anything... 

Give me a day or two and I'll verify if this still exists... 

Comment 3

17 years ago
Thomas: any updates on this? A testcase maybe?
(Reporter)

Comment 4

17 years ago
I'm going through past projects to find the URL where this failed.

I wound up patching a library of mine to always output an ENCTYPE as a workaround.
Related to bug 105636?

Then again, this deals with forms without enctype specified, and I've seen bug
105636 occur with Bugzilla (which I would think would have enctype specified).

Comment 6

17 years ago
Thomas: please attach a testcase. Could you supply a build ID (milestone#)?

Comment 7

17 years ago
From my comment in bug 105636:

go to http://www.cinebel.be/cgi/srch.exe?1,fr
choose a town (in the drop box right to "villes")
click on "aujourd'hui" (today).

this is a form without enctype

Comment 8

17 years ago
reassigning
Assignee: rods → alexsavulov
(Assignee)

Updated

17 years ago
Summary: forms without enctype are submitted multiple times → forms without enctype are submitted multiple times[form sub]
Because of the nature of forms, this bug is not easy to confirm or invalidate.

Can we get a testcase which will definitively show how many times the server
receives a form submission from the client?  A simple PHP script based on IP
address, mailing address, and IP address should suffice, I would think.
http://www.zbarsky.org:8000/~bzbarsky/formsubtest.html has a _really_ simple
testcase.  It appends a line to a file for each time the script is run and then
outputs the whole file back.  Submitting the form adds one and only one line to
the file for me (tried POST and GET both).  Marking worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

17 years ago
I haven't been able to duplicate the problems with the last weeks builds on the
forms that I thought showed the problem.

It is possible that there was a javascript that verified the input and then did
a submit... 

Lets keep it resolved for now.  If I find another example, I'll open a new bug
report or reopen this one...

Comment 12

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.