--with-system-nspr build error: 'prthread.h' file not found

RESOLVED FIXED in Firefox 27

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: b1060552, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
mozilla27
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
In file included from media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc:22:
In file included from dist/include/Latency.h:12:
In file included from dist/include/nsCOMPtr.h:34:
In file included from dist/include/nsISupportsUtils.h:26:
In file included from dist/include/nsISupportsImpl.h:25:
dist/system_wrappers/prthread.h:3:15: fatal error: 'prthread.h' file not found
#include_next <prthread.h>
              ^
1 error generated.
make[1]: *** [audio_device_alsa_linux.o] Error 1
(Reporter)

Updated

5 years ago
Blocks: 920325
Component: WebRTC → WebRTC: Audio/Video
(Reporter)

Comment 1

5 years ago
Created attachment 823052 [details] [diff] [review]
pass cflags

Pass NSPR_CFLAGS similar video_capture.gypi. cflags_mozilla can be moved
outside of build_with_mozilla block but would make it harder to see context.
Attachment #823052 - Flags: review?(rjesup)
Comment on attachment 823052 [details] [diff] [review]
pass cflags

Review of attachment 823052 [details] [diff] [review]:
-----------------------------------------------------------------

Since we're looking at uplift tomorrow, I'll also land this.
Attachment #823052 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/mozilla-central/rev/5a85d47b5642

And thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla27

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox26: --- → unaffected
status-firefox27: --- → fixed
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.