Native Focus event triggered on Click events with Firefox 24

RESOLVED DUPLICATE of bug 886268

Status

()

defect
RESOLVED DUPLICATE of bug 886268
6 years ago
6 years ago

People

(Reporter: dennisgaebel, Unassigned)

Tracking

({testcase})

24 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

Using a simple anchor tag get the anchors id using getElementById and attach an .onfocus and .onclick handler to this anchor tag with JavaScript.


Actual results:

Firefox 24 reports focused when clicked and subsequently fires the focus event. Here's the example demonstrating this =>  http://codepen.io/grayghostvisuals/pen/qrBLG


Expected results:

Focus should not be triggered on click events and only fire when using the tab key to gain focus on the anchor element.
Is this new since Firefox 24?
Component: Untriaged → DOM: Events
Product: Firefox → Core
Posted file Testcase
I can reproduce the problem also in Firefox 8 on OSX, so it's not a recent
regression.
(Reporter)

Comment 3

6 years ago
@Masatoshi
I have no clue. All I know is that the bug is currently in Firefox 24.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 886268
You need to log in before you can comment on or make changes to this bug.