CSS Transformation (e.g. scale(1,1)) disables rendering of java-applet

RESOLVED INVALID

Status

()

P5
normal
RESOLVED INVALID
5 years ago
a year ago

People

(Reporter: mails4andy, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 823243 [details]
applet-test.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20130328110703

Steps to reproduce:

The attached testcase contains a simple page with a java-applet on it. The java-applet
ist just rendering a blue background.
When the body-element has a CSS Transformation, e.g. "transform: scale(1,1)", 
then the applet is not rendering anymore.

Tested with:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 Build: 20131023004005
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

Java: Java(TM) Platform SE 6 U51 File: npjp2.dll Version: 6.0.510.30


Actual results:

Applet is not rendering. Screen remains white.


Expected results:

Applet is rendering. In this testcase there should be a blue background.

Comment 1

5 years ago
Regression range:
good=2012-07-01
bad=2012-07-02
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d9d61d199b11&tochange=a31fc9052840

Suspected bug:
Ms2ger — Bug 745523 - Part b: Unprefix transforms; r=dbaron This patch introduces unprefixed 'transform', 'transform-origin', 'perspective', 'perspective-origin', 'transform-style' and 'backface-visibility' properties, and updates the mochitests in layout/style to use them.

I guess there is probably another underlying bug with transform.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
Product: Firefox → Core
Version: 26 Branch → 16 Branch
Windowed plugins are not rendered inside transformed content, because there is no way to transform windowed stuff.  Is this applet running in windowless mode or windowed mode?

Updated

5 years ago
Flags: needinfo?(mails4andy)
(Reporter)

Comment 3

5 years ago
I don't know how to find out if the java plugin uses windowless or windowed mode.

I also tried a newer version of the java plugin (Java(TM) Platform SE 7 U45 Version: 10.45.2.18) without success.

In Chrome with "-webkit-tranform: scale(1,1)" the applet is rendering.
Flags: needinfo?(mails4andy)
(Reporter)

Comment 4

5 years ago
(In reply to mails4andy from comment #3)
> In Chrome with "-webkit-tranform: scale(1,1)" the applet is rendering.

Typo: -webkit-transform: scale(1,1);
What happens in Chrome is, iirc, that some transforms cause non-rendering (non-trivial ones) but others do not.  What does "-webkit-tranform: scale(2,2)" do?
(Reporter)

Comment 6

5 years ago
(In reply to Boris Zbarsky [:bz] from comment #5)
> What happens in Chrome is, iirc, that some transforms cause non-rendering
> (non-trivial ones) but others do not.  

I think it would be ok, if only trivial transforms are supported. Maybe rendering untransformed for the non-trivial ones ist in option?

> What does "-webkit-tranform: scale(2,2)" do?

I will upload two screenshots of Chrome with "scale(0.7,0.7)" and "scale(2,2)" using the same testcase.
(Reporter)

Comment 7

5 years ago
Created attachment 823900 [details]
chrome-transform-scale-2-2.png
(Reporter)

Comment 8

5 years ago
Created attachment 823901 [details]
chrome-transform-scale-07-07.png
Flags: needinfo?(roc)
Does it work if you add <param name="wmode" value="opaque">
or <param name="wmode" value="transparent">
Flags: needinfo?(mails4andy)
We could support scale+translate transforms of windowed plugins by scaling the window size, but it would be complicated and probably not worth doing.
Flags: needinfo?(roc)
(Reporter)

Comment 11

5 years ago
(In reply to Mats Palmgren (:mats) from comment #9)
> Does it work if you add <param name="wmode" value="opaque">
> or <param name="wmode" value="transparent">

Both parameters does not make any difference.
Flags: needinfo?(mails4andy)
Keywords: regression, regressionwindow-wanted
Priority: -- → P5
The HTML <applet> element and related java functionality was removed from Gecko in Bug 1279218. Marking related bugs as invalid.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.