Add preferences to configure the grid size in the panel

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: the1edmeister, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P-][Australis:M-])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

As Australis is now configured the Customize and Control UX panel has 3 icon columns and will extend as many rows as needed for the icons placed in that panel, creating an overflow scrollbar as needed.


Actual results:

On my monitor (1280 x 768 pixels) 3 icons wide by 10 horizontal rows creates an overflow scroll bar - with 28 icons in that panel.


Expected results:

I request that 2 user preferences be added (hidden or in about:config by default) which would allow the user to specify the width and max height of the Customize and Control UX panel via specifying the number of columns and number of rows, similar to the preferences for the New Tab Page.
browser.newtabpage.rows & browser.newtabpage.columns

Updated

5 years ago
Component: Layout → Untriaged
Product: Core → Firefox

Updated

5 years ago
Severity: normal → enhancement
Component: Untriaged → Toolbars and Customization
Version: unspecified → Trunk
(In reply to the-edmeister from comment #0)
> On my monitor (1280 x 768 pixels) 3 icons wide by 10 horizontal rows creates
> an overflow scroll bar - with 28 icons in that panel.

Is this because we're approaching the edge of your screen?

I don't think we'd block Australis on adding a hidden preference for this since it wouldn't be worth the maintenance cost. An extension can likely provide this functionality.
Blocks: 872617
OS: Windows XP → All
Hardware: x86 → All
Summary: Request for Enhancement: Customize and Control UX - Australis → Add preferences to configure the grid size in the panel
Whiteboard: [Australis:P-]
(Reporter)

Comment 2

5 years ago
Yes, it extends down over the Task Bar within ~10px of the edge of the screen.

The Add-on Bar will be gone and users won't be able to create a Custom Toolbar, where are users supposed to place toolbar buttons when they have a large number of extensions installed? Room for 28 icons just may not cut it, especially when adding other extensions to replace features that have been removed. I'm filling the grid already with about half the number extensions I routinely use in Firefox, due to number of extensions that aren't yet compatible with UX.
To be clear, I agree that this is a problem, I just don't think a hidden preference that <1% of the user base will change is the right solution. It seems like extensions can already address the issue by adding customizable toolbars[1] or allowing the user to configure the panel size. If we find that this is a common problem, we can address this in a different way.

[1] http://aris-at-mozilla.blogspot.ca/2013/10/modifiy-australis-ui-11-custom-toolbars.html
Whiteboard: [Australis:P-] → [Australis:P-][Australis:M-]
(In reply to Matthew N. [:MattN] from comment #3)
> To be clear, I agree that this is a problem, I just don't think a hidden
> preference that <1% of the user base will change is the right solution. It
> seems like extensions can already address the issue by adding customizable
> toolbars[1] or allowing the user to configure the panel size. If we find
> that this is a common problem, we can address this in a different way.
> 
> [1]
> http://aris-at-mozilla.blogspot.ca/2013/10/modifiy-australis-ui-11-custom-
> toolbars.html

I guess a List view will make everybody happy right ?
(Reporter)

Comment 5

5 years ago
This user style is an acceptable solution to this Bug report.
http://userstyles.org/styles/97314/australis-menu-list-view
(In reply to the-edmeister from comment #2)
> Yes, it extends down over the Task Bar within ~10px of the edge of the
> screen.
Still an issue on low resolutions, nightly 29.0a1 (2014-01-27), win 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

a year ago
Resolved wontfix after Photon?
Flags: needinfo?(the1edmeister)
(In reply to Kuba Niewiarowski from comment #7)
> Resolved wontfix after Photon?

Sounds right. The app menu panel no longer has a grid of icons.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.