Elastic overscroll patches still have impact when not enabled

VERIFIED FIXED in mozilla28

Status

()

Core
Widget: Cocoa
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mstange, Assigned: spohl)

Tracking

Trunk
mozilla28
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
In yesterday's UX build, swiping is disabled, but scrolling past the page end and back again behaves differently than before the swiping patches. Is this intentional?

STR:
1. Ensure swipe pref is off.
2. Put two fingers on the touchpad.
3. Move your fingers up or down until you hit the edge of the page.
4. Keep scrolling further in the same direction.
5. Reverse direction (still without lifting your fingers) and scroll a bit.

Actual results:
Step 5 does not cause any scrolling until you've crossed the imaginary overscroll bound again.

Expected results:
The page should start moving again as soon as you've reversed the scroll direction.
(Assignee)

Comment 1

4 years ago
No, not intentional. I've checked with a local build and I can't reproduce. However, latest nightly does repro. Will check for a regression range.
Assignee: nobody → spohl.mozilla.bugs
(Assignee)

Comment 2

4 years ago
Created attachment 824123 [details] [diff] [review]
Patch

Turns out this was there ever since landing the patch in bug 673875. Not sure why I couldn't reproduce with a local build at first.

This patch ensures that we're not tracking vertical swipes when swipe animations are turned off.
Attachment #824123 - Flags: review?(felipc)
Attachment #824123 - Flags: review?(felipc) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4dc708bb39cb
https://hg.mozilla.org/mozilla-central/rev/4dc708bb39cb
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28

Comment 5

4 years ago
Markus, can you please check that this is fixed on Firefox 28:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/28.0b2-candidates/build1/mac/en-US/ ?
Flags: needinfo?(mstange)
(Reporter)

Comment 6

4 years ago
It's fixed in that build.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mstange)
You need to log in before you can comment on or make changes to this bug.