Closed Bug 931798 Opened 6 years ago Closed 6 years ago

Story - Auto restore session after a switch to desktop happens

Categories

(Firefox for Metro Graveyard :: General, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 28

People

(Reporter: bbondy, Assigned: bbondy)

References

Details

(Whiteboard: [completed-oak][block28] feature=story c=tbd u=tbd p=1)

Attachments

(1 file, 1 obsolete file)

When starting up the browser the following pref is checked:
browser.sessionstore.resume_session_once

If it is set to true then the session is restored. 
Then the pref is auto reset to false.
(See http://dxr.mozilla.org/mozilla-central/source/browser/components/sessionstore/src/nsSessionStartup.js#l139 for more info, but not needed for this task).

This bug is to set that pref to true before switching to Desktop.

We should also add browser.sessionstore.resume_session_once to the list of shared prefs here:
http://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#l4757

p=1
Summary: Auto restore session after a switch to desktop happens → Story - Auto restore session after a switch to desktop happens
Whiteboard: feature=story c=tbd u=tbd p=1
Whiteboard: feature=story c=tbd u=tbd p=1 → [block28] feature=story c=tbd u=tbd p=1
Whiteboard: [block28] feature=story c=tbd u=tbd p=1 → [release28] feature=story c=tbd u=tbd p=1
Assignee: nobody → netzen
Blocks: metrov1it18
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Blocks: metrov1it19
No longer blocks: metrov1it18
For oak only for now
Attachment #831473 - Flags: review?(msamuel)
Attachment #831473 - Flags: review?(msamuel) → review+
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: [release28] feature=story c=tbd u=tbd p=1 → [block28] feature=story c=tbd u=tbd p=1
https://hg.mozilla.org/projects/oak/rev/9da01190f0e5

Bug 935099 will track the landing on m-c.
When it lands on m-c a new comment will be added here as well with the m-c changeset.
This is being done so we can still use scrumbugs efficiently. 
See bug 935099 for further details.
Blocks: 935099
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Carrying forward r+
Attachment #831473 - Attachment is obsolete: true
Attachment #8334650 - Flags: review+
Repushed to post-australis oak:
https://hg.mozilla.org/projects/oak/rev/eecf7c2a4823
Whiteboard: [block28] feature=story c=tbd u=tbd p=1 → [completed-oak][block28] feature=story c=tbd u=tbd p=1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
https://hg.mozilla.org/integration/fx-team/rev/fb3ae66def36
Target Milestone: --- → Firefox 28
https://hg.mozilla.org/mozilla-central/rev/fb3ae66def36
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
- on Win 8.1 Pro, with latest Nightly

If I open the desktop browser, "browser.sessionstore.resume_session_once" is set to false by default. When I switch to Metro browser, the pref has the value true. Then, when I relaunch in Desktop mode, the value of the pref is still false.

Is this the intended behavior?
Flags: needinfo?(netzen)
I don't think so but this will be covered in a different session restore working consistently bug if needed.
Flags: needinfo?(netzen)
But are the steps from comment 7 the right ones to follow, in order to verify this bug?
Flags: needinfo?(netzen)
I'm not sure how to verify this because the browser can change it on startup.
Flags: needinfo?(netzen)
Does anyone have any suggestions in how to verify this issue?
Flags: needinfo?(msamuel)
I think the intended effect of this bug is to ensure that a session is restored when switching to/from desktop and metro, instead of starting a new session. So verifying that the tabs are carried to the other mode is an example. However, the session restore may not be done 100% correctly yet, since bug 924886 is still in progress.
Flags: needinfo?(msamuel)
Marking this verified as fixed, for iteration #20, based on comment 12: a session is restored (almost 100% correctly, considering bug 924886 as mentioned above) when switching to/from Desktop and Metro.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.