Closed Bug 931834 Opened 6 years ago Closed 6 years ago

New infobar design is broken on Windows

Categories

(DevTools :: Inspector, defect)

x86
Windows 8
defect
Not set

Tracking

(firefox27 verified, firefox28 verified)

VERIFIED FIXED
Firefox 28
Tracking Status
firefox27 --- verified
firefox28 --- verified

People

(Reporter: paul, Assigned: aljullu)

References

Details

Attachments

(1 file)

See attachment 823373 [details]. We can see the buttons' borders.
Depends on: 927815
Not sure but maybe is this line of my previous patch?

> .highlighter-nodeinfobar-button {
>   -moz-appearance: none;
>-  border: 0 solid hsla(210,8%,5%,.45);
>   padding: 0;
>   width: 26px;
(In reply to Albert Juhé from comment #1)
> Not sure but maybe is this line of my previous patch?
> 
> > .highlighter-nodeinfobar-button {
> >   -moz-appearance: none;
> >-  border: 0 solid hsla(210,8%,5%,.45);
> >   padding: 0;
> >   width: 26px;

Yes. I believe doing this should work:

>  .highlighter-nodeinfobar-button {
>   -moz-appearance: none;
>-  border: 0 solid hsla(210,8%,5%,.45);
>+  border-width: 0;
I have Windows 7 installed in a virtual machine but I am not sure if it will be able to build Firefox. Is there any other way to test it?
(In reply to Albert Juhé from comment #3)
> I have Windows 7 installed in a virtual machine but I am not sure if it will
> be able to build Firefox. Is there any other way to test it?

I'll provide you a build. Attach a patch, I'll do the rest. Thanks!
Assignee: nobody → aljullu
Comment on attachment 823425 [details] [diff] [review]
Bug 931834 - New infobar design is broken on Windows; r=paul

Yep. That works.
Attachment #823425 - Flags: review?(paul) → review+
Albert, once you get a r+, add "checkin-needed" in the keyword field (I changed your bugzilla privileges, you can now confirm bugs and edit all aspects of any bug).
Keywords: checkin-needed
Done, thanks. ;-)
https://hg.mozilla.org/mozilla-central/rev/f081f22d4eff
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28
Comment on attachment 823425 [details] [diff] [review]
Bug 931834 - New infobar design is broken on Windows; r=paul

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 927815
User impact if declined: windows user will see grey lines in the infobar
Testing completed (on m-c, etc.): fx-team, m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #823425 - Flags: approval-mozilla-aurora?
Attachment #823425 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.2; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 6.2; rv:28.0) Gecko/20100101 Firefox/28.0

Verified as fixed on latest Aurora (buildID: 20131107004005) and latest Nightly (buileID: 20131107030200).
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.