[contacts] if usb storage enabled, Import Contacts list says user needs to put in a sd/memory card despite having one in the device

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: aryx, Assigned: sergi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Boot2Gecko 1.2.0.0-prerelease 20131028142239 on Keon, update channel default

If the USB storage has been enabled and is in use, the Import Contacts list (where you can choose the import source) says the user needs to put in a memory card despite having one in the device.
Assignee: nobody → sergi.mansilla
Actually, isn't that expected behavior? Perhaps the message should be improved, though. Thoughts?
Flags: needinfo?(francisco)
E.g. Camera and Video have strings which tell the user to unplug the device. From Camera:

pluggedin2-title = Camera can not be used while phone is plugged in
pluggedin2-text = Unplug the phone to capture photos and videos
We could use better strings, but definitely the storage is not available.
Flags: needinfo?(francisco)
This issue has been fixed since: if USB storage is enabled, "Cannot use memory cad because USB storage is enabled" is displayed in the Import Contacts panel.

Tested on:
Gaia-Rev        6af3a8a833eb8bb651e8b188cb3f3c3a43bb4184
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/76b85b90a8cb
Build-ID        20141111040202
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.jlorenzo.20141002.104456
FW-Date         Thu Oct  2 10:45:09 CEST 2014
Bootloader      L1TC00011880
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.