Closed Bug 931901 Opened 8 years ago Closed 7 years ago

pathfinder.gr doesn't redirect to mobile site on Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alefteris, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-gr][serversniff][sitewait])

Site: http://www.pathfinder.gr
pathfinder.gr doesn't redirect to mobile site on Firefox OS and Firefox for Android

:: Steps To Reproduce

1. Open Firefox OS browser
2. Type pathfinder.gr in Firefox OS browser address bar

also

1. Open Firefox for Android app
2. Type pathfinder.gr in Firefox for Android address bar

:: Expected Result

Get redirected to http://i.pathfinder.gr. When typing the web site address on iOS Safari we get redirected to the mobile site.

:: Actual Result

We receive the desktop site of http://www.pathfinder.gr

:: Additional Information

Firefox OS
Software Version: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
Device Information: Keon

Firefox for Android Beta
Software Version: Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0
Device Information: ZTE Blade
Whiteboard: [country-gr]
Depends on: 931905
They're looking for some iOS strings in the UA to redirect to the i subdomain.

mtaylor at omg-2 in ~/tmp
$ http --print=Hh http://www.pathfinder.gr User-Agent:"iPhone"
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.pathfinder.gr
User-Agent: iPhone

HTTP/1.1 302 Found
Connection: Keep-Alive
Content-Encoding: gzip
Content-Length: 20
Content-Type: text/html
Date: Tue, 29 Oct 2013 21:48:57 GMT
Keep-Alive: timeout=2, max=77
Location: http://i.pathfinder.gr/
Server: Apache
Vary: Accept-Encoding
X-Pad: avoid browser bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-gr] → [country-gr][serversniff][contactready]
See Also: → 931905
* Firefox for Android is now redirected to http://mobile.pathfinder.gr/
* Firefox OS is still getting the desktop content on http://www.pathfinder.gr/
Summary: pathfinder.gr doesn't redirect to mobile site on Firefox OS and Firefox for Android → pathfinder.gr doesn't redirect to mobile site on Firefox OS
Trying a human contact pointing to this bug. 
We should try to get also Bug 931905 resolved.
http://twitter.com/MozWebCompat/status/485970974202798081
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-gr][serversniff][contactready] → [country-gr][serversniff][sitewait]
The issue is still here. 
The version which is sent to Firefox Android (http://mobile.pathfinder.gr/) is working perfectly with Firefox OS.

It's really just a matter of User agent sniffing.

I will recontact the CTO through twitter.
This has been resolved. Thanks a lot.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.