crash in mozilla::a11y::SelectionManager::ProcessSelectionChanged(nsISelection*)

VERIFIED FIXED in Firefox 27

Status

()

Core
Disability Access APIs
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tracy, Assigned: surkov)

Tracking

({crash, topcrash-win})

27 Branch
mozilla28
x86
All
crash, topcrash-win
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ verified, firefox28+ verified)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-385aef50-37c3-4b46-abec-87c312131028.
=============================================================

several comments indicate attempting to compose an email in gmail.

Most of these crashes are on Win 8/8.1

Comment 1

4 years ago
Alex, is this due to the text selection event reorg?
(Assignee)

Comment 2

4 years ago
(In reply to Marco Zehe (:MarcoZ) from comment #1)
> Alex, is this due to the text selection event reorg?

it is, simple null check will help
(Assignee)

Comment 3

4 years ago
Created attachment 823959 [details] [diff] [review]
patch
Assignee: nobody → surkov.alexander
Attachment #823959 - Flags: review?(trev.saunders)
Attachment #823959 - Flags: review?(trev.saunders) → review+
7-day Nightly Rank:
 * Firefox 27.0a1: #3 (19.20%)
 * Firefox 28.0a1: #2 (13.37%)
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?
Keywords: topcrash

Updated

4 years ago
Keywords: topcrash → topcrash-win

Updated

4 years ago
status-firefox26: --- → unaffected
tracking-firefox27: ? → +
tracking-firefox28: ? → +
https://hg.mozilla.org/mozilla-central/rev/1a486a62b1f3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox28: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
We're gonna fix this in Aurora too, right? I can't compose emails currently
(Assignee)

Comment 8

4 years ago
Comment on attachment 823959 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 928504
User impact if declined: crashes
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: no
Attachment #823959 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Attachment #823959 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Reporter)

Comment 10

4 years ago
Sort the Reports tab by build ID. There are no reports of 28.0a1 builds crashing after 20131101030205.

I have no idea why the Table tab shows data for more recent builds.
status-firefox28: fixed → verified
https://hg.mozilla.org/releases/mozilla-aurora/rev/51ae975337bf
status-firefox27: affected → fixed
Keywords: checkin-needed

Comment 12

4 years ago
(In reply to [:tracy] Tracy Walker - QA Mentor from comment #10)
> Sort the Reports tab by build ID. There are no reports of 28.0a1 builds
> crashing after 20131101030205.
> 
> I have no idea why the Table tab shows data for more recent builds.

The Reports tab has multiple pages, but sorting only sorts the current page and not the whole list. The Table tab probably samples the whole list.
(Reporter)

Comment 13

4 years ago
There are no reports of this happening with builds from 11/5 or 11/6.
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
You need to log in before you can comment on or make changes to this bug.