Closed Bug 931948 Opened 11 years ago Closed 10 years ago

Make sure we show the right ratings in the right regions

Categories

(Marketplace Graveyard :: Consumer Pages, enhancement, P1)

enhancement

Tracking

(Not tracked)

VERIFIED FIXED
2013-12-10

People

(Reporter: clouserw, Assigned: kngo)

References

Details

Certain regions are familiar with certain ratings boards (eg. ESRB in the US, but DEJUS in Brazil).  We should only show 1 rating in each region - if there is a specific one we'll use that, otherwise we should use our GENERIC one.  There is a table in the spec below with the 5 ratings boards and which regions to show them in.


UX: https://bugzilla.mozilla.org/show_bug.cgi?id=929805

Our Spec: https://docs.google.com/a/mozilla.com/document/d/1vc-pDhbFYKMDbA3Yamr8InA2M7kerBdc39qzPwIUMqk/edit#
 
IARC docs: https://docs.google.com/a/mozilla.com/file/d/0B96RwPRmGwk7LWc5Zjhrc2V5WXM/edit?usp=sharing
Assignee: nobody → kngo
I pretty much did all of this in bug 929625, except the "Generic" fallback case. Look at the relevant commits and let me know if you need any help:

https://github.com/mozilla/zamboni/commit/2deea87
https://github.com/mozilla/fireplace/commit/5739235
https://github.com/mozilla/flue/commit/d5467ab
Added more ratings bodies and ratings: https://github.com/mozilla/zamboni/pull/1308
Merged in, but ratings bodies are commented out in constants/regions.py as to not disable games in other countries other than Brazil/Germany until we are ready.

Once we flip the waffle, uncomment the ratings body lines. But otherwise, the ratings bodies are correctly associated to their countries.
https://github.com/mozilla/zamboni/pull/1420
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
There's a region discrepancy on this piece of the implementation - 
currently says "USA & Canada" - actually ESRB is currently "All Americas except Brazil"

is this something we need to fix now? can we address sooner rather than later?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
So Colombia, Venezuela, Mexico, Peru, Uruguay, Argentina should be using ESRB?
Flags: needinfo?(cgalimidi)
Flags: needinfo?(cgalimidi)
This is correct.  Thanks for adjusting.
Merged.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-12-10
Please add STR here or mark it with [qa-] if no QA is needed.
Flags: needinfo?(clouserw)
Use the table on page 4 of the spec in comment 0 to find which ratings bodies should show up in which regions.  Rate an app, then visit the detail page in each of the regions and make sure the right ratings bodies appear.
Flags: needinfo?(clouserw)
I have checked all the regions and noticed that
Argentina, Colombia, Mexico, Peru and Uruguay shows ESRB
For the rest of the regions the rating body is displayed correctly. http://screencast.com/t/JTci6K3n2
Is this the expected behavior?
Flags: needinfo?(clouserw)
yes, ESRB is correct for North/Central/South America.
Flags: needinfo?(clouserw)
* Save Brazil, who have their own thing
Thank you Wil!
Verified as fixed in https://marketplace-dev.allizom.org/ on FF29 (Win 7).
Postfix screencast http://screencast.com/t/JTci6K3n2
Closing bug.
Status: RESOLVED → VERIFIED
A couple of comments on the screencast results - 

Germany was still displaying "0" Icon instead of "Refused Classification".
Chile was displaying the Generic Rating Icon and not the ESRB Rating Icon.
Italy was displaying the Generic Rating Icon and not the PEGI Rating Icon.
All South and Central American countries seemed to be displaying the English ESRB Icons, not the Bi-lingual English/Spanish ESRB Icons.
Thanks for the catches, I just set Chile to use ESRB and Italy to use PEGI (https://github.com/mozilla/zamboni/commit/efd7294ad4704436375e6868198da15f242574eb).

This app hasn't been updated since I last fixed the Germany "Refused Classification" issue, which is why it is still showing "0".

Spanish icons should be displayed if we detect the user's language to be set to Spanish, rather than what region they are viewing in.
Postfix for Chile and Italy http://screencast.com/t/xh7ihoibrMSw
Iulian, Can you please do me a big favor and create a screencast with the US, Brazil, Germany, Spain and Italy?  I would like to send it to the IARC participants to view.  Thank you.
(In reply to David Kassack from comment #19)
> Iulian, Can you please do me a big favor and create a screencast with the
> US, Brazil, Germany, Spain and Italy?  I would like to send it to the IARC
> participants to view.  Thank you.

Sure, no problem! http://screencast.com/t/7AFvphk3
I have logged this issue for content rating text for ES language and region 958135
Thank you.  One more comment about this.  While I know that this is an example, I was hoping to find out how Mozilla will handle an app that receives a "Rating Refused" rating from Germany.  I assume it will not be made available in that locale.  Is that the case?
Andrew, how would reviewers handle apps that receive a "Rating Refused" rating from Germany? Would reviewers reject it?
Flags: needinfo?(awilliamson)
(In reply to Kevin Ngo [:ngoke] from comment #22)
> Andrew, how would reviewers handle apps that receive a "Rating Refused"
> rating from Germany? Would reviewers reject it?

No, it may still be acceptable in other regions, depending on its content.  Will Marketplace remove (and block) the Germany region?  (reviewers don't have access to edit an app's regions, fwiw)
Flags: needinfo?(awilliamson)
A good example of this type of content is any app/game that contains a swastika.  They are illegal in Germany.  The app will need to be blocked in Germany.
Andrew, reviewers can escalate the app for admins to review, and then we can add functionality for Senior Reviewers to exclude an app from certain regions (override region settings). How would that sound?

This wouldn't block launch since a Refused Rating would be rare and those apps could stay in the queue while this feature is implemented.
(In reply to Kevin Ngo [:ngoke] from comment #25)
> Andrew, reviewers can escalate the app for admins to review, and then we can
> add functionality for Senior Reviewers to exclude an app from certain
> regions (override region settings). How would that sound?
> 
> This wouldn't block launch since a Refused Rating would be rare and those
> apps could stay in the queue while this feature is implemented.

Yes, it could be escalated.  Of course a developer could simply add it back though without us being notified.
We'd make it so the developer wouldn't be able to add it back. And put it in the re-review when the ratings are changed.
Though another way would be to let the app be pushed, but just automatically exclude Germany for apps with USK Refused Rating with some sort of notification?
(In reply to Kevin Ngo [:ngoke] from comment #28)
> Though another way would be to let the app be pushed, but just automatically
> exclude Germany for apps with USK Refused Rating with some sort of
> notification?

The ideal solution seems (to me) to be for any regions with a refused rating to be disabled as soon as the rating is received (I don't know which other regions have a refused rating). Regions that can be set by the developer, but then not set again once a senior reviewer has unset them sounds overly complicated.
Currently only USK has a Refused Rating.

Here's what I think:

1. App gets a USK Refused Rating and makes it to the review queue.
2. A reviewer escalates it.
3. A senior reviewer pushes the app to public (with a comment about Germany).
4. The system automatically disables the app for Germany.
5. The developer receives new content ratings that removes the USK Refused Rating.
6. Either the app goes into re-review or the system automatically re-enables the app for Germany.
why not:

1. App gets a USK Refused Rating
2. The system automatically disables the app for Germany.
3. A reviewer reviews it as normal
4. The developer receives new content ratings that removes the USK Refused Rating.
5. Either the app goes into re-review or the system automatically re-enables the app for Germany.

The escalation step doesn't seem necessary if the senior reviewer doesn't need to do anything.
Two thoughts - 

1.  Currently, only Germany has a refused classification rating.  Australia will be joining the system at some point this year and when they do, they will also have a refused classification.

2.  I'm concerned with this point in comment 31 - 

"A reviewer reviews it as normal".

Can you clarify what you mean?

Thanks
The reviewer can ignore the Rating Refused if we have our system automatically disable the app for Germany, and thus "review it as normal".
OK.  Thanks.
You need to log in before you can comment on or make changes to this bug.