Pinning/unpinning sites result in wrong thumbnails being shown

RESOLVED DUPLICATE of bug 926430

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 926430
4 years ago
a year ago

People

(Reporter: bnicholson, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 823468 [details]
screenshot

I've found a couple of ways to reproduce this:

STR #1:
1) Go to about:home and pin any site in positions 2-6
2) Click the thumbnail to go to that site
3) Click back
4) Unpin site

If the thumbnails then shift around as a result of the unpin, you'll hit this bug. If the thumbnails don't shift, repeat steps 1-4 until you trigger a frecency change.

STR #2:
1) Go to about:home and pin any site
2) Long press any other thumbnail and choose Edit
3) Select the same page that was pinned in step 1

In both STR #1 and #2, the pinned site will have its thumbnail duplicated in another slot. Screenshot attached.

Updated

4 years ago
status-firefox26: --- → ?
Possibly a dupe of Bug 926430, at least as far as the root cause is concerned.
My fix in Bug 926430 addresses this -- thumbnails are always correct. Duping to that.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926430
tracking-fennec: ? → ---
status-firefox26: ? → ---
You need to log in before you can comment on or make changes to this bug.