If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Contacts] A Facebook friend with the same name will not be recommended as a possible match if a saved contact has special characters in their name

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun3)

Attachments

(1 attachment)

Created attachment 823482 [details]
LinkSpecialCharacersFacebook.mp4

Description:
A Facebook friend with the same name will not be recommended as a match if the saved contact name on the phone has a special character in their first and last name.  

Repro Steps:
1)  Updated Buri to Build ID: 20131025004000
2)  Create a contact on the phone that has the same first name and last name as a Facebook contact that the user will be importing. Put a special character after their first name and a special character after their last name. For example: Kevin$ Trevor*
3) Tap on the contact that was just created and then tap on "Link contact".
4) Sign into Facebook.

Actual:
Notice the message "no matching friends found" even though the contact has the same name as the Facebook contact but has a special character in their first and last name.

Expected:
The Facebook friend with the same name as the saved contact should be recommended as a possible match.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131025004000
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5eabd267ef04
Gaia: 606517ceafe0950c2b89822d5f13353743334f2c
Platform Version: 26.0a2
RIL Version: 01.02.00.019.082 

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/5215/
See attached: video clip
This issues reproduces on Leo v 1.1.0 COM RIL

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20131024041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/e4cb5a852e3d
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Platform Version: 18.1
RIL Version: 01.01.00.019.264 

The Facebook contact with the same name will not be recommended because the saved contact has a special character in the first and last name.
This issue is by design. We don't support auto-merge for FB contacts because of a partner contract.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.