[B2G][Browser] "Try Again" button works only once in "Offline" mode

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g18 unaffected, b2g-v1.2 affected)

Details

(Whiteboard: burirun3)

Attachments

(1 attachment)

959.70 KB, video/quicktime
Details
(Reporter)

Description

5 years ago
Created attachment 823639 [details]
IMG_0300.MOV

Description:
When opening "Browser" without connection, the "Offline mode" page opens with "Try Again" button after tapping the button one time, it's disable for the next time

Prerequisites:
No internet connection

Repro Steps:
1) Updated Buri to BuildID: 20131025004000
2) Open the browser page without internet connection
3) Tap the "Try Again" button

Actual:
"Try Again" button are clickable only once

Expected:
"Try Again" button is clickable every time

Device:  Buri v1.2 Mozilla RIL
BuildID: 20131025004000
Gaia: 606517ceafe0950c2b89822d5f13353743334f2c
Gecko: 5eabd267ef04
Version: 26.0a2
RIL Version: 01.02.00.019.082 
Firmware Version: US_20131015

Notes:
Repro frequency:100%
See the video attachment
(Reporter)

Comment 1

5 years ago
The issue doesn't reproduce on Leo 1.1 COM RIL

Device: Leo v1.1 COM RIL
BuildID: 20131028041204
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Gecko: 41c15ddb7216
Version: 18.0
Firmware version:01.01.00.019.264
status-b2g18: --- → unaffected
status-b2g-v1.2: --- → affected

Updated

5 years ago
blocking-b2g: --- → koi?
Component: Gaia::Browser → Gaia::System
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
Component: Gaia::System → Gaia::Browser
This is a Gecko bug, not a Gaia bug and may be reproduceable in more than just the browser app (where there's an easy user workaround of hitting the refresh button).

In the past I've seen this page in apps as well as browser tabs, where the overlay has failed to display. If this were to happen the user could get trapped on this page and would have to kill the app to reload it. If that's the case, I would block on this.
Component: Gaia::Browser → General
I'm going to hold off nominating until we dig into the root cause here. This could be intentional change maybe - the video shows the button becoming disabled after one use. I get the feeling that was changed for a reason. The regression range will help identify why.
blocking-b2g: koi? → ---
Interestingly enough, this also reproduces on Firefox for Android. Which makes me someone intentionally changed this.

Updated

5 years ago
See Also: → bug 910893
Did some digging around - apparently this is a legitimate bug. It's similar to the Fennec bug 910893. What I find strange here is that the code for this error page that was borrowed existed from Fennec 8, which makes me think this bug has existed since 1.01. Can someone recheck if this reproduces on 1.1? I'm not convinced this isn't already present on 1.1.
status-b2g18: unaffected → ?
Keywords: regression, regressionwindow-wanted → qawanted
Summary: [B2G][Browser] "Ty Again" button works only once in "Offline" mode → [B2G][Browser] "Try Again" button works only once in "Offline" mode

Comment 6

5 years ago
This issue does not reproduce on the Buri 1.1 Com and Moz RIL Build ID: 20131029041202

Gaia   39b0203fa9809052c8c4d4332fef03bbaf0426fc
SourceStamp 41c15ddb7216
BuildID 20131029041202
Version 18.0

Steps used in an attempt to reproduce: 

1. Launch www.twitter.com with no Wi-Fi or data connection. 
2. When offline error appears, press try again. (Pressed "Try Again" 10x) 
3. Enable Data and Wi-fi connection.
4. Press "Try Again" (Page then reloads successfully to twitter site) 

Also, I tried to reproduce with steps from comment 0 but was unsuccessful in reproducing.
Keywords: qawanted
I think I know what happened here then & what regressed this. Fabrice mentions that the network error used to be implemented in gecko in past releases, but in 1.2 moved the entire implementation over to the System app. This was likely a fallout on the migration over. Given that Fennec has shipped with this problem for a long time, we probably don't need to worry about dropping everything & fixing this.
status-b2g18: ? → unaffected
Component: General → Gaia::System
Keywords: regression
We reimplemented the offline handling and it seems like it works now. Lets reopen if it still reproduces.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.