Firefox sync addon compatibility issues: Use an older version if not compatible

RESOLVED DUPLICATE of bug 1393929

Status

()

RESOLVED DUPLICATE of bug 1393929
5 years ago
5 months ago

People

(Reporter: hong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20131022185104

Steps to reproduce:

Set up Firefox Sync on a Firefox 25 and a Firefox 17. Then there is one addon (the latest version vimperator) which is not compatible for Firefox 17.


Actual results:

After syncing, the incompatible version was installed on Firefox 17.


Expected results:

For Firefox 17, an old version should be installed to keep them compatible.
(Reporter)

Updated

5 years ago
Component: Untriaged → Extension Compatibility
OS: Linux → All
Hardware: x86_64 → All
Component: Extension Compatibility → Add-ons Manager
Product: Firefox → Toolkit
Component: Add-ons Manager → Firefox Sync: Cross-client
Product: Toolkit → Mozilla Services
Version: 17 Branch → unspecified
Only desktop Sync supports add-on sync, so moving to Backend.

I'm pretty sure this is a WONTFIX, though. Add-ons are increasingly version-agnostic, and we very much want to discourage people from using outdated, less secure, slower versions of Firefox -- the current ESR release is Firefox 24, so there's no way we want to make it more likely that you'll stick with 17.
Status: UNCONFIRMED → NEW
Component: Firefox Sync: Cross-client → Firefox Sync: Backend
Ever confirmed: true
(Reporter)

Comment 2

5 years ago
Actually when I opened this ticket, the ESR is 17.0.x.

Basically what I am talking about is mainly ESR version and the latest version. Some addons may drop the support of an older version -- the current ESR version may also be dropped. So syncing between the current ESR version and the latest version can be a problem.
Thom has a good analysis of how we decide which add-on version to install in bug 1393929, comment 4. The TL;DR is that we trust the add-on's compatibility info on AMO, and this should be less of an issue in the WebExtensions world.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1393929
(Assignee)

Updated

5 months ago
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.