Closed Bug 932198 Opened 6 years ago Closed 5 years ago

Convert nsSVGPatternFrame from using gfxASurface to using Moz2D APIs

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33
Tracking Status
firefox32 + fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
This patch can't land just yet until filters are converted to use a Moz2D backed temporary draw target. Without that these two test fail:

layout/reftests/svg/filters/filter-patterned-rect-01.svg
layout/reftests/svg/filters/filter-patterned-rect-02.svg

layout/reftests/svg/filters/filter-patterned-rect-01.svg
layout/reftests/svg/filters/filter-patterned-rect-02.svg
Attachment #823879 - Flags: review+
Duplicate of this bug: 930734
Blocks: 703159
Blocks: 933019
Depends on: 987190
Comment on attachment 823879 [details] [diff] [review]
patch [r=longsonr in bug 931769]

https://hg.mozilla.org/integration/mozilla-inbound/rev/617e3d552045

The filter code is now only propagating Thebes backed gfxContexts rather than creating them, so I've landed this now. I had to fuzz a couple of the font tests.
Attachment #823879 - Flags: checkin+
Blocks: 1025652
https://hg.mozilla.org/mozilla-central/rev/617e3d552045
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Comment on attachment 823879 [details] [diff] [review]
patch [r=longsonr in bug 931769]

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 994081
User impact if declined: Certain SVG images fail to render completely on all platforms. See bug 1025652 .
Testing completed (on m-c, etc.): Tested on B2G, landed on m-c.
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch: None
Attachment #823879 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1025652
(In reply to Michael Wu [:mwu] from comment #5)
> Risk to taking this patch (and alternatives if risky): 

There's probably less likely to be SVG breakage taking this patch than not, no I agree we should.
Comment on attachment 823879 [details] [diff] [review]
patch [r=longsonr in bug 931769]

Aurora approval granted.
Attachment #823879 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
Depends on: 1242256
You need to log in before you can comment on or make changes to this bug.