All users were logged out of Bugzilla on October 13th, 2018

Enable Hindi (hi) locale for MDN

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kaustavdm, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:feature][newlang])

(Reporter)

Description

5 years ago
What problems would this solve?
===============================
MDN articles can be translated to Hindi, which is one of the primary languages of India and is spoken by 180 million people.

Who would use this?
===================
Users speaking Hindi

What would users see?
=====================
MDN articles translated to Hindi

What would users do? What would happen as a result?
===================================================
MDN can be used by people speaking Hindi.

Is there anything else we should know?
======================================
(Reporter)

Updated

5 years ago
Assignee: nobody → jbeatty
Component: General → Localization
Product: Mozilla Developer Network → Developer Documentation
hello,

i would like to translate this Bug into Hindi Language. So where to start .

Updated

5 years ago
Assignee: jbeatty → nobody
Component: Localization → Localization
Product: Developer Documentation → Mozilla Developer Network
This is also related to bug 895006. Adding this as a blocker to 895006.
Blocks: 895006

Updated

5 years ago
Whiteboard: [specification][type:feature] → [specification][type:feature][newlang]

Updated

5 years ago
Severity: normal → enhancement
Fixed in https://github.com/mozilla/kuma/pull/2259
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Maris, the requested locale was hi not hi-IN why have you created hi-IN?
Flags: needinfo?(mars)
Duplicate of this bug: 952842
:groovecoder, please see comment 4
Status: RESOLVED → REOPENED
Flags: needinfo?(mars) → needinfo?(lcrouch)
Resolution: FIXED → ---
I copied the approach of https://www.mozilla.org/hi-IN/ and https://support.mozilla.org/hi-IN/home to match what they did with Verbatim: https://localize.mozilla.org/hi_IN/

Do we need to change it?
Flags: needinfo?(lcrouch)
Flags: needinfo?(jypenator)
No, no, I was curious :-) That's a good reason, it solves several problem as other web sites often just copy the locale of their own page.

Note that in some case, it may be more critical (like if a language is spoken by two countries at war where contributors of one country may refuse to contribute on the language just because of the locale.
Flags: needinfo?(jypenator)
(In reply to Jean-Yves Perrier [:teoli] from comment #8)
> No, no, I was curious :-) That's a good reason, it solves several problem as
> other web sites often just copy the locale of their own page.

Ah, I misunderstood then.  I thought we needed (hi) specifically, not (hi-IN).  Can we close this bug?
We were requested hindi translation, but we can do this with hi or with hi-IN. 
(And to be fair, I found good reasons to do hi-IN after my original question ;-) So you don't really misunderstood me)

Let's close this :-)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

5 years ago
I had asked for hi based on the same convictions mentioned in comment 8. But hi-IN works just as well for now. Hope the localization team does a good work here.
You need to log in before you can comment on or make changes to this bug.