Session is not restored when running mozmill restart tests

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 824011 [details] [diff] [review]
Patch with the mozmill restart test

Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0

Session is not restored at restart when running the attached mozmill-restart tests. The steps of the test:
1. Open the browser
2. Load a pdf
3. Navigate to page 2
4. Restart the browser
Expected result: After restart, the tab with the pdf is restored.
Actual result: After restart, the tab with the pdf is not restored.
* Note that this works as expected when running the steps manually. Also, it works as expected when running the mozmill test on the 26.0 branch.

Regression range:
* Last good nightly: Oct 17 2013
* First bad Nightly: Oct 18 2013

Pushlog:
* mozilla-central: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=423b9c30c73d&tochange=4e7d1e2c93a6
* mozilla-inbound: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b9c6098feb81&tochange=976228f4aef7
Probably caused by bug 900910. Not sure what mozmill is doing here, though.
Mihaela, as already requested please test inbound builds. The range of changesets is still too long.
Flags: needinfo?(mihaela.velimiroviciu)
(Reporter)

Comment 3

5 years ago
This is the shortest range I could find with the existing inbound builds (ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-linux/) and it corresponds to builds 
1382098090 (good) and 1382098937 (bad).

> Pushlog:
> * mozilla-inbound:
> http://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=b9c6098feb81&tochange=976228f4aef7
Flags: needinfo?(mihaela.velimiroviciu)
Why is that the shortest range? I can see way more builds in this folder so we should be able to get this reduced to the actual changeset.
(Reporter)

Comment 5

5 years ago
I locally built the changeset before landing the patch for bug 900910 (1cb3ba2ab9c1) and the one one for bug 900910 (1374158dab4b) and it seems that bug 900910 is the root cause for this issue: running the mozmill restart test on changeset 1cb3ba2ab9c1 restores the session but on changeset 1374158dab4b it doesn't.
Anyway, the issue seems to be fixed on latest Nightly 28.0a1 (20131029030201) and Aurora 27.0a2 (20131029134505) builds: session is restored when running the mozmill restart test. Hence, marking this bug WFM.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Yeah, we had a couple of regressions from bug 900910 that should be fixed now, sounds plausible.
You need to log in before you can comment on or make changes to this bug.