SUMO prod database is having issues

RESOLVED FIXED

Status

Data & BI Services Team
DB: MySQL
P1
blocker
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: rrosario, Assigned: sheeri)

Tracking

Details

(Reporter)

Description

4 years ago
It seems to be there and we are connecting to it. But it's acting as if the users table is empty or something like that. I can't see much more because I can't log in to the site :(

Help?
Making this a P1.

We're getting thousands of errors right now.
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All
(Assignee)

Comment 2

4 years ago
Checking this out.
(Assignee)

Comment 3

4 years ago
The auth_user table is corrupt, I'm repairing it now.
(Reporter)

Comment 4

4 years ago
I see some stack traces that say:

DatabaseError: (1146, "Table 'support_mozilla_com.auth_user' doesn't exist")

OY

https://errormill.mozilla.org/support/support/group/125879/

After that, we are getting thousands of stack traces.
OS: All → Mac OS X
Priority: P1 → --
Hardware: All → x86
(Reporter)

Comment 5

4 years ago
sorry about that.
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All
Assignee: server-ops-database → ludovic
(Assignee)

Comment 6

4 years ago
Had to go to yesterday's backup on this one, importing now.
Assignee: ludovic → scabral
(Assignee)

Comment 7

4 years ago
import complete, let's look to see what users are still missing.
(Assignee)

Comment 8

4 years ago
Imported missing user ids as per http://scabral.pastebin.mozilla.org/3375054
Questions missing and pages in questions missing; reported: https://support.mozilla.org/en-US/forums/contributors/709708#thread-reply
Sheeri, could you create these users too?

987917
987939
987975
988015
988026
988028
988071
988089
988090
988115
988141
988225
988256
988319
988404
988413
988419
(Assignee)

Comment 11

4 years ago
I have inserted those users.
We've got a bunch of foreign keys pointing to things in the auth_user table. I think it's easier and less time consuming on all of us if we just create auth_user entries for the missing ids in that period rather than fix the issue that keep arising.

I grabbed the latest dump and built the list of ids that were missing. There are 493 of them:

https://pastebin.mozilla.org/3382495

Given that I'm working on a dump, that will not reflect some of the accounts created since the dump was created.

Can we create shell auth_user entries for those ids?
(Assignee)

Comment 13

4 years ago
493 users created (19 duplicates, so really only 474 users created on top of the 19 already made).
Thank you Sheeri!

I think we should be fine now given that we've recreated all the auth_user entries that could possibly have been missing (unless I messed up my SQL when I generated the list (which is entirely possible)). I'm ok with closing this bug out now. We can either reopen if there are more things that need to be fixed in the db or open up new bugs.

Ricky, Kadir: Does that work for you two?
(Reporter)

Comment 15

4 years ago
yep, bd from me. I think we are done here. ^5s all around.
(Assignee)

Comment 16

4 years ago
It's been about a week since we had problems, so I'm going to mark this resolved as it has not cropped up again (phew!)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Sorry, missed this question here. Just to be sure: Yes, works for me.
Product: mozilla.org → Data & BI Services Team
You need to log in before you can comment on or make changes to this bug.