Firefox Hangs Windows XP with Radeon 2400 XT

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

24 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
FF 24.0

At least once a day my Windows XP system hangs when Firefox is loading page content. It always happens while a page is painting and never at another time like scrolling or switching tabs. It took a long time by process of elimination to pinpoint Firefox. Disabling hardware acceleration in Firefox seems to have cured the problem, but this is a serious issue and many novice user will probably have no idea that Firefox is even responsible for system hangs.

I'd like to figure out how to assist in debugging the cause, but once the system hangs there's no way to interact with it. I'm not sure how to help isolate the cause.

This is with the latest official drivers for the Radeon 2400 XT (8.970.100.7000).
(Reporter)

Comment 1

5 years ago
I stand corrected. Disabling hardware acceleration did not cure the problem. It happened again this morning. I clicked a link and as soon as the page began to paint my whole system hung. I have WebGL AND hardware acceleration disabled.
Unfortunately a frozen system is always a bug in the system or in one of the drivers. Firefox is a user mode application and can not freeze the system. You can always open the taskmanager and kill the Firefox process if this would be a Firefox bug.
It's possible that only Firefox trigger the bug in the video driver (as example) but it's still a bug in the video driver. 
We can't fix this on our side because this happens only on your system and also in third party software.
Debugging such issues is possible but very complicated and requires a second system with a debugging environment installed. Microsoft has some documentation about that process.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.