[10.9] Mavericks naps during the build while the screen was locked leading to an over 6 hour long build

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
10 months ago

People

(Reporter: MattN, Unassigned)

Tracking

Trunk
All
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 824185 [details]
./mach resource-usage output

I started a build around midnight PDT and shortly after I used the fast user switching menu to switch to the login window to lock my screen. When I returned to my computer in the morning, the Firefox build was still in-progress.

I don't have good STR yet but I'm filing it in case others notice this. Terminal.app doesn't seem to have App Nap specifically enabled because there isn't a checkbox on the Get Info page of it. I suspect 10.9 is trying to save energy even though I was plugged into AC power.

We might be able to do a workaround[1] at the start of a build with
  defaults write com.apple.Terminal NSAppSleepDisabled -bool YES
if this turns out to be App Nap.

I'll give that a try and see if it helps and see how reproducible this is.

[1] http://www.tekrevue.com/tip/disable-app-nap-os-x-mavericks/
Created attachment 824190 [details]
./mach resource-usage image

Sorry, I thought the data was included in the HTML file
Attachment #824185 - Attachment is obsolete: true
Created attachment 824192 [details]
./mach resource-usage json
I've built the tree a number of times on Mavericks and never seen this -- though it may be because I usually check the build's progress every 5-10 minutes.  I'll try to do a build overnight (or over dinner), without checking, and see what happens.

By the way, the following setting is available in the Energy Saver System Pref panel, going back at least to OS X 10.6:

Put the hard disk(s) to sleep when possible.

This is on by default, but I always uncheck it.

Have you changed this setting from its default?  And if not, does unchecking this make a difference?
(In reply to Steven Michaud from comment #3)
> I've built the tree a number of times on Mavericks and never seen this --
> though it may be because I usually check the build's progress every 5-10
> minutes.  I'll try to do a build overnight (or over dinner), without
> checking, and see what happens.

Switching to the Login Window may be required to reproduce but I don't know yet.

> Put the hard disk(s) to sleep when possible.
> 
> This is on by default, but I always uncheck it.
> 
> Have you changed this setting from its default?  And if not, does unchecking
> this make a difference?

That setting is still on and I didn't have any problems prior to Mavericks.
> That setting is still on and I didn't have any problems prior to Mavericks.

It might make a difference on Mavericks, though.

> Switching to the Login Window may be required to reproduce but I don't know yet.

I'll try that, later today.
I'm pretty sure this is not specific to Mavericks. I've always had to enable Caffeine [0] before starting overnight builds to prevent this from happening.

[0] http://lightheadsw.com/caffeine/
I just had a loaner MBP (read: no 3rd party software) running Mavericks and the only thing I needed to do was set the power options for "computer sleep" to "never" when running on AC power. The machine would enter screen saver after a few minutes and builds would keep chucking. I didn't explicitly use the fast user switching mode, however. I dunno.
I've never had a problem before and I regularly do builds overnight. I also don't think I ever installed software for that. It's possible that the upgrade to Mavericks changed my Energy Saver preferences to put the computer to sleep earlier (currently set to 15min. on AC) but I can't say for sure.
Note that I upgraded from Lion so this may have been an issue with Mountain Lion.
I just tried a 64-bit build of the current tree on Mavericks, twice -- once with "Put the hard disk(s) to sleep when possible" set, once without.  In both cases I switched to the login window immediately after starting the build.  In both cases I ran with the power connected.

In neither case did the build process "nap" or "sleep".  These builds normally take about 15 minutes, and that's exactly what they took.

I suspect the people who see this problem have it because their computer is set to sleep too soon.  Mine is set never to sleep (either on the battery or with the power adapter).
After increasing the sleep time the problem went away. I still think something during the 10.7=>10.9 upgrade process reset that or OS X is just more aggressive at sleeping now (even with disk I/O from a build).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.