Redraw (e.g., on pin) of favicons in Top Sites causes flicker

RESOLVED WORKSFORME

Status

()

Firefox for Android
Awesomescreen
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

({polish})

Trunk
All
Android
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
* Load about:home.
* Pin or unpin a site.
* Observe that favicons (not thumbnails) flicker: backdrop color goes to white then back to the specified background color.

Ideally we shouldn't be redrawing the whole thing anyway -- we can't help it, because we observe the DB -- but if we do, we shouldn't be showing visual artifacts.
(Reporter)

Comment 1

5 years ago
Is this still an issue? Flagging me as needinfo in case QA doesn't get to this.
Flags: needinfo?(rnewman)
Keywords: qawanted

Comment 2

5 years ago
I've tried this with a Galaxy Nexus (Android 4.3) & Galaxy Tab 2 (Android 4.2) and I am not able to reproduce it - not seeing a flicker. 
I think this is a worksforme but please reopen if you will see it again (or if it is reproducing only on a certain device/architecture)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

4 years ago
No longer reproduces for me either. Yay!
Flags: needinfo?(rnewman)
You need to log in before you can comment on or make changes to this bug.