Closed Bug 932633 Opened 8 years ago Closed 8 years ago

PopupNotifications are incorrectly cancelled by subframe navigation

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 915951

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

(Whiteboard: [CTPDefault:P2])

Attachments

(2 files)

Once PopupNotifications.show is called, any navigation of a *frame* within that page destroys the popup notification. I'm about 99.44% sure this is never what we want, and it breaks the plugin doorhanger at https://www.mojebanka.cz/InternetBanking/
Online testcase: http://benjamin.smedbergs.us/tests/ctptests/flash-solo.html and click "navigate subframe".
Attachment #824409 - Flags: review?(dolske) → review+
This has the same fix as bug 915951 and that one also has r+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915951
You need to log in before you can comment on or make changes to this bug.