control a no longer goes to beginning of line in a text box

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Perry Wagle, Unassigned)

Tracking

25 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Go to a text box, like this one.
Press control e on a line with something on it.  Then press control a.


Actual results:

Control e goes to end of line, like the emacs key binding AND the macosx gui standard.
Control a goes does some sort of search thing, UNLIKE the emacs key binding AND the macosx gui standard.


Expected results:

Text box has focus, find should not override with a completely novel interpretation of the control a key.  I bought a Mac so I'd have more of a consistent typing experience, and firefox wants to turn that all on its head by inventing its own key bindings that are not even consistent: ending the find search box turns the beginning of line behavior back on.
Hi,

I didn't managed to reproduce this issue on the latest release(43.0.4) nor the latest Nightly(46.0a1).

User Agent:  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160113135947

Can you please try to reproduce this on the latest release(43.0.4) and latest Nightly(46.0a1) and provide the results?
When doing this, you could create a new clean Firefox profile, or maybe test in safe mode, as some of this issues may be caused by third party installed addons or custom settings
(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Here is a link with keyboard shortcuts https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly . Maybe this will be helpful.

Thank you,
Vlad
Flags: needinfo?(wagle)
(Reporter)

Comment 2

3 years ago
It was definitely doing it when I reported it, but I haven't noticed it recently.
Flags: needinfo?(wagle)
Due to the fact that I cannot reproduce the issue and also the reporter cannot reproduce it, I will Close the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.