If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TB 24.0 + Lightning 2.6.1 -> Lightning error message at start of TB

RESOLVED DUPLICATE of bug 925823

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 925823
4 years ago
4 years ago

People

(Reporter: b1161928, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028112627

Steps to reproduce:

I'm not aware of having changed anything.
I have been using Ubuntu 13.04 with TB & Lightning successfully for a while now.

Since some days ago, when i start TB an error message comes up.


Actual results:

At the start of Thunderbird an error message comes up:

"An error was encountered preparing the calendar located at moz-abmdbdirectory://abook.mab for use. It will not be available."

Error Code:
0x80570015

Discription:
[Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]"  nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///home/snark/.thunderbird/jvsqd8v0.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: <TOP_LEVEL> :: line 22"  data: no]


Expected results:

No error & working calendar.

Comment 1

4 years ago
You'll have to match Thunderbird and Lightning versions:
- Thunderbird 24.0 needs Lightning 2.6
- Thunderbird 24.0.1 needs Lightning 2.6.1
- Thunderbird 24.1.0 needs Lightning 2.6.2

Duplicate of bug 931347 which in turn resolved as duplicate of bug 925823.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925823

Comment 2

4 years ago
[Triage note: I've left this in Thunderbird on purpose so that it shows up in TB-specific searches.]
(Reporter)

Comment 3

4 years ago
Thanks for your help!

Now think i have an idea how the different versions of TB & Lightning occured on my system:

I immigrated my TB Folder (including Lightning) from a windows machine a while ago. That way Lightning worked at first. I guess then the auto update feature updated TB to a version that wasn't compatible to my (former windows) lightning addon anymore which caused the error I reported. (To me it seems that because of my copy&paste immigration of TB+Lightning the calendar addon weren't updated properly.)

Reinstalling Lightning in the addons menu of TB solved the issue.
You need to log in before you can comment on or make changes to this bug.