Closed Bug 932764 Opened 6 years ago Closed 6 years ago

The slide up animation is not smooth for Gaia keyboard

Categories

(Core :: Graphics, defect)

26 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla28
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: rudyl, Assigned: BenWa)

References

Details

(Keywords: perf, regression, Whiteboard: [c=effect p= s= u=1.2])

The keyboard slide up became not that smooth.
video to demo this issue, http://youtu.be/K0rIIpuk7Bw

I think this might be a Gecko regression because I cannot reproduce this with a older Gecko + the same latest Gaia rev, 8b65283997529014189d603c97fbeb77fbaeb6a7

Cannot reproduce
----------------
Gecko:    http://hg.mozilla.org/mozilla-central/rev/182b8450e32f
BuildID   20131020040204
Version   27.0a1

Can repro
=========
Gecko:    c9df655c01dbbf840b41153e53ef249445fa6556
BuildID   20131030061537
Version   28.0a1
A video of this working might help when getting the regression window. Don't know where smooth transitions would fall under - maybe gfx?
Keywords: perf
If it's a performance issue, probably graphics.  One quick thing to try is to turn off off main thread animation and see how that affects the result. Smaller than 10 day regression range would be awesome as well, thanks for asking for it.
QA Contact: nkot
Regression range:

-last working-
BuildID: 20131022040242
Gaia: 50f544a7530c266aab9bbc9a893e00e15d34c02f
Gecko: 177bf37a49f5
Version: 27.0a1

-first broken-
BuildID: 20131023040203
Gaia: 6d23c2f9153d0e1d17679cb9c317e75a0ee9a490
Gecko: 21d97baadc05
Version: 27.0a1
Nominate this issue as koi+ since it is a regression and would affect the user experience when using the keyboard.
blocking-b2g: --- → koi?
Component: General → Graphics
Product: Firefox OS → Core
Version: unspecified → 26 Branch
Assignee: nobody → gwright
Whiteboard: [c=effect p= s= u=]
Assignee: gwright → bgirard
The lag is obvious. Plus it for address it in koi
blocking-b2g: koi? → koi+
Status: NEW → ASSIGNED
Whiteboard: [c=effect p= s= u=] → [c=effect p= s= u=1.2]
I'm going to get to this bug soon but wanting to wrap up another bug first.
Depends on: 936866
This needs bug 927324 (depends on bug 936866 which is a duplicate of bug 927324), and it seems to be a keyboard app issue.  Do we still want it for koi?
blocking-b2g: koi+ → koi?
We are blocking on this as keyboard perf is critical for 1.2 and this is a regression , also ccing david.
blocking-b2g: koi? → koi+
Benwa, can you take a break and profile this. We can put other people on the fixes but we are blocked on making progress here until we know whats up.
Depends on: 936864
(In reply to Andreas Gal :gal from comment #9)
> Benwa, can you take a break and profile this. We can put other people on the
> fixes but we are blocked on making progress here until we know whats up.

I did a bit of profiling for bug 936864 but didn't upload the profile. I think pulling up the keyboard has never been fast enough to render at even 10 FPS but it's always been masked because previously we had async animations working. The real fix here I think is bug 936864 which I will work on tomorrow. We should however get some fixes for bug 927324 on master.
Here's a profile I took. This shows that opening the keyboard takes 500ms which is a bit unlikely. I'll confirm my measurements tomorrow:
http://people.mozilla.org/~bgirard/cleopatra/#report=dcaaf63dd8d844d576634c8e59d6677fa9d854e3
If by the end of this week this isn't confidently resolved, we're going to recommend a backout of bug 910697. Comments 5 and 60 in that bug suggest that it was difficult to reproduce.
Rudy can you verify that this issue is fixed on trunk?
Flags: needinfo?(rlu)
(In reply to Alex Keybl [:akeybl] from comment #12)
> If by the end of this week this isn't confidently resolved, we're going to
> recommend a backout of bug 910697. Comments 5 and 60 in that bug suggest
> that it was difficult to reproduce.

How do you backout code that is not even landed? I am a bit confused.
(In reply to Benoit Girard (:BenWa) from comment #13)
> Rudy can you verify that this issue is fixed on trunk?

I found the animation is smooth with m-c and Gaia master,
--
Device: Unagi
Gaia:     5d2ce56dbfbba702a487cd17efd19cdd62b2ff57
Gecko:    http://hg.mozilla.org/mozilla-central/rev/f2adb62d07eb
BuildID   20131118094134
Version   28.0a1

Do we have any specific bugs that have addressed this issue?
Flags: needinfo?(rlu)
The animation looks great on v1.2 as well,
Gaia:     7a23f8c53ba97da9c63a7275b36d155b4526a639
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/3e8b854a992e
BuildID   20131118004001
Version   26.0

--
Guess we can close this as fixed now.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Hi, Rudy,

Thanks for your help.
Verified it. I cannot reproduce this bug on V1.2 latest build.

* Test Build:
 - Gaia:     5ec2963fff60492c840707df8d8090f9908a5251
 - Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/2d454e0de2ed
 - BuildID   20131120004000
 - Version   26.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.