Pseudoelement disregarding parent positioning context when parent is display: table-cell

VERIFIED DUPLICATE of bug 35168

Status

()

VERIFIED DUPLICATE of bug 35168
5 years ago
5 years ago

People

(Reporter: filip, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 824641 [details]
pseudoelement_table_bug.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

I used an :after pseudoelement inside a relatively positioned table-cell parent and positioned it absolutely.


Actual results:

The pseudoelement isn't positioned in the context of it's relative parent, but in the context of the next closest element that isn't display: table-cell.


Expected results:

The pseudoelement should be positioned in the context of it's relative parent (table-cell).
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
I didn't look at the testcase too closely, but I'm betting the problem is just that relative positioning of table cells doesn't work yet. (bug 35168)  Duping to that bug, since this should presumably work once that's fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 35168
Yep.

Note that per spec using "position: relative" on a table cell has undefined behavior...
Status: RESOLVED → VERIFIED

Updated

5 years ago
Duplicate of this bug: 932785
Incidentally, it's bug 63895 that deals with the issue of position:relative table elements being an abspos containing block, as opposed to that of position:relative actually moving table elements.
You need to log in before you can comment on or make changes to this bug.