Closed Bug 932824 Opened 8 years ago Closed 8 years ago

The overlay to Activate Adobe Flash is briefly displayed

Categories

(Core :: Plug-ins, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: adalucinet, Unassigned)

References

Details

Reproducible on:
Firefox 26 beta 1 (Build ID: 20131028225529): 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
latest Aurora (Build ID: 20131028004004):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
latest Nightly (Build ID: 20131030030201):
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:28.0) Gecko/20100101 Firefox/28.0

Steps to reproduce:
1. Launch Firefox.
2. Go to about:config and set the value for plugins.click_to_play to true (if not already enabled).
3. Go to Tools->Addons and set Flash to Ask to Activate.
4. Navigate to http://mixlr.com/wxb102/chat/

Actual results: 
The overlay to Activate Adobe Flash is displayed for a second and it disappears.

Notes:
1. Reproducible also on Ubuntu.
I don't know which particular patch fixed it, but this works with my current patch queue: probably bug 915951.
I'll re-test when bug 915951 hits Nightly
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #0)
> Actual results: 
> The overlay to Activate Adobe Flash is displayed for a second and it
> disappears.
Still reproduces on 28.0a1 (2013-11-03), after the fix of bug 915951
This issue is not a regression; It's reproducible on Firefox 24: since the new CTP design landed (bug 880735).
Glancing quickly at this it could also be a site issue. It looks like the site may just insert the plugin(s) and only resize them to 1x1 later, as the CtP overlay shouldn't overflow the plugin elements size visibly.
With our changes to make the CtP overlay stay on top in more situations, it may have become only visible in more recent Firefox versions (e.g. Fx23 for bug 752516).
There's nothing to fix here. The site shows a plugin, changes its size, and we correctly show the blue plugin icon (and will show the infobar, when that lands).
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
See also bug 937606 for a similar (I'm not saying identical) issue with SeaMonkey.
(In reply to Tony Mechelynck [:tonymec] from comment #7)
> See also bug 937606 for a similar (I'm not saying identical) issue with
> SeaMonkey.

Oops: bug 937616
That is a different issue:
This is about the overlay on the plugin (in-content/in-page) being briefly visible, while bug 937616 (and bug 926605 for Fx) is about keeping the notification around in the location bar.
This problem started for me on FF31 (nightly) and has been there ever since. Now on FF32 (nightly), the page will show a placeholder with the text 'activate adobe flash' and the entry 'Activate this plugin' in the context menu. Activating either of these makes the 'activate' popup request briefly flash on the screen. On some pages (eg. Youtube, when the page is scrolled so that the plugin placeholder is (partly) covered by the location bar) I can get the activation request to appear in a bar under the location bar, pressing 'allow' there has the same effect (flashing popup).

While there is probably a relation between the layout of the page and this bug hitting, it can not be rightly blamed on page layout. Click to Play should not be so easily broken by odd page layouts. Maybe an icon in the location bar, similar to the popup blocker icon, can be used? It would be more consistent as well.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
As an aside, I use FF nightly (now at 32) on Linux (x86_64), running Xmonad.
This is still about the in-content overlay flashing (see comment 9 etc), not the popup.
Please open a new bug with a URL where this happens and specific steps to trigger it.

If you've only started to see this recently you could try narrowing it down using mozregression:
http://mozilla.github.io/mozregression/
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.