[Settings] 1.3 Visual Refresh of Settings icons

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: amylee, Assigned: pivanov)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: visual design, visual-tracking, jian)

Attachments

(5 attachments, 4 obsolete attachments)

(Reporter)

Description

5 years ago
A refresh of some of the settings icons for 1.3.
(Reporter)

Updated

5 years ago
Blocks: 925925
(Reporter)

Updated

5 years ago
Assignee: amylee.design → pivanov
(Reporter)

Comment 1

5 years ago
Created attachment 8333514 [details]
Settings_Sprite.zip

Hi Pavel, 

Attached are the updated settings sprites. Please note that a new icon has been added to the sprite (chat bubble - messages). Let me know if you have any questions 

Thanks
Created attachment 8333766 [details] [review]
patch for Gaia/master
Attachment #8333766 - Flags: feedback?(epang)
Comment on attachment 8333766 [details] [review]
patch for Gaia/master

Redirecting feedback from Amy for this bug since she made the changes to the settings icons.  Amy I'll attached screen caps of the updated icons since I know you won't be able to flash Pavel's patch.  If all good please give the patch Feedback+ so Pavel can ask for review.  Thanks!
Attachment #8333766 - Flags: feedback?(epang) → feedback?(amylee.design)
Created attachment 8333780 [details]
Screens of new setting icons
Flags: needinfo?(amylee.design)
(Reporter)

Comment 5

5 years ago
Created attachment 8333902 [details]
Settings_Sprite_v2.zip

Hey Pavel, 

I noticed that some of the icons aren't centered. I've adjusted the sprite so the icons are sitting centered to bounding boxes of 30x30px and 45x45px. Hopefully this fixes the alignment issue. Can you please replace the sprites with the ones I've attached? 

Also, the sprite background colour set is to #F4F4F4. This is the background colour for v1.3 build. It's slightly lighter than the old build so I assume that the background colour of settings will be changed to this for the 1.3 visual refresh?
Flags: needinfo?(amylee.design)
(Reporter)

Comment 6

5 years ago
Created attachment 8333929 [details]
Settings_Icons_1.3.zip

Hi Pavel, 

Here are the rest of the icons for settings that need to be replaced. Let me know if you have any questions. Thanks!
Hey Eric can you help with the latest icons, as we talk?
Created attachment 8334527 [details]
settings icons.zip

Hi Pavel, I've organized the setting icons into the gaia structure.  Thanks!
Attachment #8333514 - Attachment is obsolete: true
Attachment #8333902 - Attachment is obsolete: true
Attachment #8333929 - Attachment is obsolete: true
Flags: needinfo?(pivanov)

Updated

5 years ago
Attachment #8333766 - Flags: feedback?(amylee.design)
flag me for feedback when ready :) thanks!
Attachment #8333766 - Flags: feedback?(epang)
Created attachment 8336929 [details]
images to overwrite.zip

Hi Pavel, I just tested the patch.  A few of the images need to be replaced.  Can you use the images attached to replace the ones currently in the patch?  Thanks!
Hey Eric,
Sure, can you check the PR again?
Flags: needinfo?(pivanov)
Comment on attachment 8333766 [details] [review]
patch for Gaia/master

everything looks good now, thanks Pavel!
Attachment #8333766 - Flags: feedback?(epang) → feedback+
Attachment #8333766 - Flags: review?(ehung)

Comment 13

5 years ago
Comment on attachment 8333766 [details] [review]
patch for Gaia/master

looks good to me, thank you. :)
Attachment #8333766 - Flags: review?(ehung) → review+

Comment 14

5 years ago
merged into gaia master: https://github.com/mozilla-b2g/gaia/commit/568cf51284a14e4e855d01a43b355925b09a8e04
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

5 years ago
Hi Pavel, 

I'm still noticing that there is a slight difference in colour between the sprite background and the settings background (you can see faint box outline around each icon). The background colour should be #f4f4f4

Thanks
Flags: needinfo?(pivanov)
(Reporter)

Comment 16

5 years ago
Hey Pavel, 

I just found the bug for changing the settings background. So please disregard my last message. Thanks!


(In reply to Amy from comment #15)
> Hi Pavel, 
> 
> I'm still noticing that there is a slight difference in colour between the
> sprite background and the settings background (you can see faint box outline
> around each icon). The background colour should be #f4f4f4
> 
> Thanks
Yeah :) no problem ... I made the patch for the Bug 941628 :)
Flags: needinfo?(pivanov)
(Reporter)

Comment 18

5 years ago
Created attachment 8340105 [details]
Settings_Sprite.zip

Hey Pavel, 
There's been a request to adjust the size and weight of two of the icons (Device Info and Help).

Can you please replace the sprites? Thanks
(Reporter)

Comment 19

5 years ago
Created attachment 8340108 [details]
Settings_Sprite_v2.zip

Here are the static and active states of the sprites
Attachment #8340105 - Attachment is obsolete: true
(In reply to Amy from comment #19)
> Created attachment 8340108 [details]
> Settings_Sprite_v2.zip
> 
> Here are the static and active states of the sprites

Hey Amy,
Since this bug is already marked resolved fixed can you open a new followup bug and add it to the google doc?  Make sure to attach the assets for Pavel as to the other bug.  Thanks!
Flags: needinfo?(amylee.design)
(Reporter)

Comment 21

5 years ago
(In reply to Eric Pang [:epang] from comment #20)
> (In reply to Amy from comment #19)
> > Created attachment 8340108 [details]
> > Settings_Sprite_v2.zip
> > 
> > Here are the static and active states of the sprites
> 
> Hey Amy,
> Since this bug is already marked resolved fixed can you open a new followup
> bug and add it to the google doc?  Make sure to attach the assets for Pavel
> as to the other bug.  Thanks!

Hi Eric, I've created a follow-up bug 944536.
Flags: needinfo?(amylee.design)
Duplicate of this bug: 944306
You need to log in before you can comment on or make changes to this bug.