Cannot preinstall a packaged app without network connection in a SIM customization variant

RESOLVED FIXED in Firefox 28

Status

RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: amac, Assigned: amac)

Tracking

({regression, verifyme})

26 Branch
mozilla28
ARM
Gonk (Firefox OS)
regression, verifyme
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 wontfix, firefox27 wontfix, firefox28 fixed, b2g-v1.2 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 2 obsolete attachments)

+++ This bug was initially created as a clone of Bug #927959 +++

Bug 927959 broke the installation of packaged apps when the device doesn't have network at boot-up time.

STR

1. Follow https://wiki.mozilla.org/B2G/QA/Customizations#Build_Setup to setup your build with a AT&T Mobile US SIM included
2. Complete the FTE

Expected

Packaged apps should be installed and useable.

Actual

Packaged apps get the grey rocket icon, and are on pending state.

I think the problem is on:

    if (Services.io.offline) {
      let onlineWrapper = {

at the start of onInstallSuccessAck. I'll upload a proposed patch in a few minutes (as soon as my compilation ends and I can try it out)
Requesting koi since apps should be installable without having network connection (and this was introduced as a regression from 927959).
blocking-b2g: --- → koi?
Obvious 1.2 blocker
blocking-b2g: koi? → koi+
Created attachment 824700 [details] [diff] [review]
bug932843.patch

Skips the online validation for local installed apps (which actually don't need to be online to install).
Attachment #824700 - Flags: review?(fabrice)
You're only talking about the operator variant packages, right? not packaged apps from the store?
(In reply to Fabrice Desré [:fabrice] from comment #4)
> You're only talking about the operator variant packages, right? not packaged
> apps from the store?

Yeah. Packaged apps from the store can't be installed when not online anyway, so they're not affected by this. But operator variant packaged apps can (and should) be installed when not online.
Comment on attachment 824700 [details] [diff] [review]
bug932843.patch

Review of attachment 824700 [details] [diff] [review]:
-----------------------------------------------------------------

I don't like that we pass aData.app.localInstallPath here, since you don't use the path. Change that for something more semantic like:
onInstallSuccessAck(aManifestURL, aDontNeedNetwork)
Attachment #824700 - Flags: review?(fabrice) → review-
Created attachment 825667 [details] [diff] [review]
V2, includes review comments

Changed the parameter passed as requested on the previous review.
Attachment #824700 - Attachment is obsolete: true
Attachment #825667 - Flags: review?(fabrice)
Blocks: 927959
No longer depends on: 927959
Comment on attachment 825667 [details] [diff] [review]
V2, includes review comments

Review of attachment 825667 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with nit fixed

::: dom/apps/src/Webapps.jsm
@@ +2159,2 @@
>      // If we are offline, register to run when we'll be online.
> +    if ((Services.io.offline) && (!aDontNeedNetwork)) {

nit: we don't need all these parentheses:
if (Services.io.offline && !aDontNeedNetwork) { ...
Attachment #825667 - Flags: review?(fabrice) → review+
Created attachment 826415 [details] [diff] [review]
V3, with nits addressed

r=fabrice
Try run at https://tbpl.mozilla.org/?tree=Try&rev=2add0a42d731
Attachment #826415 - Flags: review+
(Assignee)

Updated

5 years ago
Attachment #825667 - Attachment is obsolete: true
Try run looks good (or as good as it's going to get :P), requesting checkin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/9a123f6acb3d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Keywords: verifyme
QA Contact: jsmith
https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/5777596fa906
status-b2g-v1.2: --- → fixed
status-firefox26: --- → wontfix
status-firefox27: --- → wontfix
status-firefox28: --- → fixed
QA Contact: jsmith

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.