togglePrettyPrint threw an exception: TypeError: Reflect is undefined

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: paul, Assigned: fitzgen)

Tracking

Trunk
Firefox 28
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
In the galery app, if I try to prettify gaia_build_defer_index.js, I get this error (and the source is not prettified):

togglePrettyPrint threw an exception: TypeError: Reflect is undefined
Stack: SA__parseAST@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/devtools/server/actors/script.js:2488
resolve@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/commonjs/sdk/core/promise.js:118
then@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/commonjs/sdk/core/promise.js:43
then@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/commonjs/sdk/core/promise.js:153
SourceActor.prototype.onPrettyPrint@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/devtools/server/actors/script.js:2463
DSC_onPacket@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js:1020
ChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js -> resource://gre/modules/devtools/server/transport.js:347
Assignee: nobody → nfitzgerald
Priority: -- → P2
How are you loading the gallery app? Is this on B2G? In the simulator? Inside a nightly with all those gaia development addons?
(Reporter)

Comment 2

5 years ago
(In reply to Nick Fitzgerald [:fitzgen] from comment #1)
> How are you loading the gallery app? Is this on B2G? In the simulator?
> Inside a nightly with all those gaia development addons?

App Manager, with the device connected.
Searching for function definitions (@) might not work as well.
Ok, I am able to connect to my keon in the app manager, but I can't figure out how to start debugging the gallery app. It isn't showing up under installed apps or on the device. Help?
Flags: needinfo?(paul)
(Reporter)

Updated

5 years ago
Flags: needinfo?(paul)
Ah, I didn't have the pref for certified apps flipped. Thanks, Panos!
Created attachment 825632 [details] [diff] [review]
reflect-not-defined.patch

95% sure the problem is that Reflect.jsm isn't properly exporting its exports.

Now gonna figure out how the hell to flashing b2g works...
...aaaaaaaand I bricked my phone :(
(Reporter)

Comment 9

5 years ago
Nick, if you just change files in /toolkit/devtools/ you can just update `omni.ja`. No need to rebuild B2G.

I wrote a script for that:

https://github.com/paulrouget/firefoxos-hotfix/blob/master/update.sh
Yes, that was what I was doing with fabrice's help, but now my phone won't boot.
Ok, got my phone up with the latest keon nightly, updated to the latest fx-team, and now I can't open the toolbox when I click "debug" for the gallery app (or any other app).

Can someone test out this patch with the original STR and tell me if it fixes the problem?
I have verified that this patch fixes the issue on 1.3 (2013-10-27) for Keon.
Attachment #825632 - Flags: review?(khuey)
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/c7d9e537642a
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/c7d9e537642a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.