[Gallery] Remove border option from image editor

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Tom Herold, Assigned: Tom Herold)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131029030201

Steps to reproduce:

The gallery's image editor currently has an option to add border to an image. However, you can only specify white or black rectangular borders, both of which are boring. Since this feature is hardly ever used it will be removed to make more space for other image editor options like auto enhance and rotating the image.



Expected results:

The border option has to be removed from the code base.

Updated

5 years ago
Assignee: nobody → dflanagan
Duplicate of this bug: 934796
Created attachment 827791 [details] [diff] [review]
Remove border-drawing code

Here is a patch that removes the border-drawing WebGL code, but leaves the UX unchanged because that aspect is totally outside my comfort zone. Hopefully, it will save you some time for when you write the patches removing the borders feature.

My interest in this comes from the fact that the way that border drawing was implemented was very unfriendly to mobile GPUs, with this branching in the fragment shader. The present patch increases the gallery preview framerate by roughly a factor of 2x; it is the most important part of the low-hanging-fruit-in-gallery-webgl-code that's being tracked in bug 934787.
(Assignee)

Comment 3

5 years ago
Created attachment 8334240 [details] [review]
Github Pull Request

Updated

5 years ago
Assignee: dflanagan → heroldtom
(Assignee)

Updated

4 years ago
Attachment #8334240 - Flags: review?(dflanagan)
Comment on attachment 8334240 [details] [review]
Github Pull Request

Looks good to me, and seems to work. Fabrice has given approval to land.
Attachment #8334240 - Flags: review?(dflanagan) → review+
Landed to master: https://github.com/mozilla-b2g/gaia/commit/43385f5a4cb9a84898b02813b3579dd06bdab10b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
I actually had this patch sitting around for about two weeks but couldn't properly test it on Travis. Everytime Travis would just stop executing tests or stall for another reason. I only submitted it for review after the Travis job finally passed.
You need to log in before you can comment on or make changes to this bug.