Status

()

--
critical
VERIFIED WORKSFORME
17 years ago
12 years ago

People

(Reporter: jo.hermans, Assigned: attinasi)

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2+) Gecko/20010801
BuildID:    2001080108

This is a site of a big Belgian bank, in 3 languages as is the custom in my
country. When you choose the Dutch welcome page, it crashes immediately. The
other languages (French, English) are fine.

Reproducible: Always
Steps to Reproduce:
1. go to www.bbl.be
2. click on 'nederlands'
3. 

Actual Results:  crash
(Reporter)

Comment 1

17 years ago
Created attachment 44425 [details]
Macsbug 'stdlog'

Comment 2

17 years ago
win2k 2001080114 worksforme
I can't reproduce this on Linux 2001080208.

Comment 4

17 years ago
This site crashed Mac/2001071903 immediately upon accessing http://www.bbl.be/.

Mac/2001080113 did not crash while following this bug's reproduction instructions.

Mac/2001080108 reproduced the crash condition as described in this bug. Mozilla quit 
with a Type 11 error. Restarting Mozilla and reaccessing the site resulted in success (that 
is, no crash). Restarting Mac OS, Mozilla and reaccessing the site duplicated the crash.

The site itself is a morass of at least three levels of FRAMESETs (as well as one JavaScript 
popup window) and many of the constituent pages are riddled with errors. Nevertheless, 
I created two local snapshots of the "page" in question: 1) one in which all HTML pages 
are local, and 2) one in which all HTML pages are local and are made valid and well-
formed. Unfortunately, even after thorough testing, I could not determine which if any 
particular page causes the crash from either set. Once, Mozilla crashed while accessing 
[http://www.bbl.be/content/index_home.htm], but I could not subsequenly reproduce 
that crash.

Both snapshots are attached to this bug in TAR format for further testing.

Comment 5

17 years ago
Created attachment 44469 [details]
Page snapshot including all embedded files

Comment 6

17 years ago
Created attachment 44470 [details]
Page snapshot including all embedded files, and all HTML has been made valid and well-formed.

Comment 7

17 years ago
stack seems to point to layout.
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
Keywords: crash
QA Contact: doronr → petersen

Comment 8

17 years ago
Reassigning to attinasi.
Assignee: karnaze → attinasi

Comment 9

17 years ago
Crash does not occur under Mac/2001080214.
(Reporter)

Comment 10

17 years ago
WFM on fresh 0.9.3 (build 2001080214, Mac), so it must have been solved in early
August. I did see a weird refresh page in between though, which might have been
the cause.
(Assignee)

Comment 11

17 years ago
Works For Me (Mac 0810) - marking WFM - please reopen if you are still seeing
this one with a later build
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.