Crash occurs during installation of java plugin

VERIFIED FIXED

Status

()

Core
Layout
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Jimmy Lee, Assigned: Marc Attinasi)

Tracking

({crash, pp})

Trunk
Other
Linux
crash, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Build: 2001-08-02-08-trunk(LINUX)

1. Open http://home.netscape.com/plugins/jvm.html
2. Click on Java 2 Linux Plug-in
3. Click OK from Items to Install dialog

RESULT:
Download appears to complete.  Crash occurs during installation.

EXPECTED RESULT:
No crash.

TalkBack Incident ID 33648839

Stack Trace
HTMLStyleSheetImpl::SetDocumentForegroundColor()
PostResolveCallback()
nsRuleNode::WalkRuleTree()
nsRuleNode::GetBackgroundData()
nsRuleNode::GetStyleData()
nsStyleContext::GetStyleData()
nsHTMLContainerFrame::CreateViewForFrame()
nsCSSFrameConstructor::ConstructBlock()
nsCSSFrameConstructor::ConstructFrameByDisplayType()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessChildren()
nsCSSFrameConstructor::ConstructDocElementFrame()
nsCSSFrameConstructor::ContentInserted()
StyleSetImpl::ContentInserted()
PresShell::InitialReflow()
HTMLContentSink::StartLayout()
HTMLContentSink::OpenBody()
CNavDTD::OpenBody()
CNavDTD::OpenContainer()
CNavDTD::HandleDefaultStartToken()
CNavDTD::HandleStartToken()
CNavDTD::HandleToken()
CNavDTD::HandleToken()
CNavDTD::BuildModel()
nsParser::BuildModel()
nsParser::ResumeParse()
nsParser::Parse()
nsHTMLDocument::WriteCommon()
nsHTMLDocument::ScriptWriteCommon()
nsHTMLDocument::Write()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_CallMethod()
js_Invoke()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
handleTriggerEvent()
PL_HandleEvent()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0x101a0 (0x403711a0)
libglib-1.2.so.0 + 0x11987 (0x40372987)
libglib-1.2.so.0 + 0x12001 (0x40373001)
libglib-1.2.so.0 + 0x121cc (0x403731cc)
libgtk-1.2.so.0 + 0x93e57 (0x40289e57)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1bb65 (0x4049eb65)
(Reporter)

Comment 1

16 years ago
Adding keywords crash, pp.
Keywords: crash, pp

Comment 2

16 years ago
I'm seeing the same thing.

Comment 3

16 years ago
With Linux Build ID 2001080608, I see similar behavior, but mine crashes as soon
as I click the "Java 2 Linux Plug-in" button on the referenced page. The
download never happens.

Comment 4

16 years ago
Also in 2001080708.  Crash as soon as trying to load a local copy of jre.xpi

Does it occur for other xpi files?

Comment 5

16 years ago
Still using 2001080608, I tried loading a local copy of psm.xpi, same results,
crash.
(Reporter)

Comment 6

16 years ago
Nominating!  This should be addressed sooner than later.  There doesn't seem to
be a way around this. :-(
Keywords: nsbeta1
wrong nominating keyword
Keywords: nsbeta1 → nsBranch

Comment 8

16 years ago
Works for me with a 2001081215 build.

Updated

16 years ago
Component: Installer: XPInstall Engine → Layout

Comment 9

16 years ago
Marc, installer is not in the stack, and suggestions on who might own this, or
perhaps if this is a dupe of some other problem?
Assignee: syd → attinasi
(Assignee)

Comment 10

16 years ago
I bet this works OK now - I'll try to test it.

changed QA to pmac - can you test too please? This seems pretty old.
QA Contact: jimmylee → pmac

Comment 11

16 years ago
Works for me with Linux ID: 2001090400

Comment 12

16 years ago
workforme on linux, redhat 6.2 (commercial trunk: 2001-09-05-08-trunk)
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
Verified on linux, redhat 6.2 (commercial trunk: 2001-09-05-08-trunk)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.