Region selection doesn't affect the data being graphed

VERIFIED FIXED in 2013-11-05

Status

--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: spasovski)

Tracking

2013-11-05
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
steps to reproduce:
1. Load https://marketplace.firefox.com/stats/total-visits/?start=2013-03-31&end=2013-10-30&region=rs
2. Notice the data being graphed
3. Switch between regions and see if the data varies

expected behavior:
Data is representative of the region being selected

observed behavior:
Region selection doesn't affect the data in any way

NOTE: This is true for all graphs available currently.
Might be a dupe of bug 932484
(Assignee)

Comment 2

5 years ago
Fixed on the front end: https://github.com/mozilla/marketplace-stats/commit/9a2c9d8

It seems this chart is not available by region so I removed the ability to choose one:

https://github.com/mozilla/marketplace-stats/commit/6ab5266

To see which charts can have a region filter it's best to consult the API: https://firefox-marketplace-api.readthedocs.org/en/latest/topics/stats.html
Assignee: nobody → dspasovski
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-11-05

Comment 3

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/stats on FF28 (Win 7).
Postfix screencast http://screencast.com/t/sk3dIqAh5R3
Regions were removed from  Total Visits and Total Developers.
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.