Setting an assignee doesn't change the Status field to ASSIGNED

RESOLVED WONTFIX

Status

()

bugzilla.mozilla.org
General
--
enhancement
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: mlee, Unassigned)

Tracking

Production

Details

(Reporter)

Description

4 years ago
STR

1. Create or open an existing bug in bugzilla.
2. Change the assignee to someone's bugmail address.
3. Click the [Save changes] button
4. Observe that the Status field isn't updated to ASSIGNED.

Expected
+ Status field is changed to ASSIGNED when an assignee is set.

Comment 1

4 years ago
You are requesting the exact opposite of bug 475409. This won't be implemented upstream. Moving to bmo in case they want to implement this.
Assignee: create-and-change → nobody
Severity: normal → enhancement
Component: Creating/Changing Bugs → General
OS: Mac OS X → All
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Hardware: x86 → All
Version: unspecified → Production
(Reporter)

Comment 2

4 years ago
Thanks I should add this is for bugs with an existing status of NEW.
as different teams use bugzilla differently we can't force the status field to ASSIGNED when a bug is assigned.

a common use pattern is for a bug to be assigned to someone to put it into their work queue, and then they change the status to ASSIGNED when they start actually working on it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
* QUESTION: is it possible to change this behavior by *product?* 

* for example: if the Webmaker product wanted bug status to automatically change from "new" to "assigned" when the assignee field is entered, is that possible? 

* or is this a single Mozilla-wide setting that can't be customized in that way? 

* just asking because this change would actually help our workflow quite a bit given the way we're now using tickets. thanks!
(In reply to Matt Thompson (@OpenMatt :OpenMatt) from comment #4)
> * QUESTION: is it possible to change this behavior by *product?*

this isn't possible, and would require development work to implement.

per-product probably won't be good enough as teams using different processes but the same product (eg. mozilla.org), so it would have to be per-component (inheriting from a per-product default).
Thanks for your answer Byron. Much appreciated!
Duplicate of this bug: 1226862
You need to log in before you can comment on or make changes to this bug.