Closed Bug 933094 Opened 7 years ago Closed 7 years ago

wrong touch position using NativePanZoomController

Categories

(Firefox for Android Graveyard :: Toolbar, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 776030

People

(Reporter: wbsecg1, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.34 Safari/537.36

Steps to reproduce:

I enable NativePanZoomController instead of JavaPanZoomController, in mobile/android/base/gfx/PanZoomController.java 

static class Factory {
        static PanZoomController create(PanZoomTarget target, View view, EventDispatcher dispatcher) {
            return new NativePanZoomController(target, view, dispatcher);
        }
    }


I test this page: http://mpulp.mobi/labs/ppk/widthtest.html




Actual results:

if a page has no viewport meta data, single tap position seems to be realpos_in_csspixel/3, then scroll distance is wrong, only 1/3 of your finger moved distance.


there are some other tests, none of them works, all buttons and links can not be clicked


Expected results:

scroll distance equals the distance finger moved.
OS: Linux → Android
Hardware: x86_64 → ARM
NativePanZoomController currently has all sorts of issues because we haven't been maintaining it as we made changes to AsyncPanZoomController. This is basically part of bug 776030.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: apz-fennec
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.