Printing a bugzilla bug crashes browser(while switching)

VERIFIED DUPLICATE of bug 90060

Status

()

--
major
VERIFIED DUPLICATE of bug 90060
17 years ago
17 years ago

People

(Reporter: bnesse, Assigned: dcone)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Attempt to print this bug. It should crash. Otherwise, use the one in the URL field.

Filed 2 Talkback reports. ID's TB33652036W and TB33651786X.

Found in the Netscape 6.1 RTM bits. Haven't tested against current trunk.
(Reporter)

Comment 1

17 years ago
Created attachment 44441 [details]
Stdlog from crash
(Reporter)

Comment 2

17 years ago
Tested against current Mozilla trunk with no problems. Might be branch only or
simply a "my installation" problem.

Comment 3

17 years ago
Ninoschka just tried on branch RTM on her Mac 9.x box and she had no
problem.

I also tried rtm branch on my 8.5 system and I don't crash when
trying to print out bugzilla reports.
(Reporter)

Comment 4

17 years ago
Good! Then it must be my profile or something. Marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
okay we see the problem

it happens while swithcing bug reports...meaning while loading another
bug report and hitting print before waiting to load that bug report,
you'll crash.

nbaca will add TB report.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: Printing a bugzilla bug crashes browser → Printing a bugzilla bug crashes browser(while switching)

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 90060 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
this is switching problem which will be addressed in 90060.

verified.
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
Branch build 2001-07-26-21: Mac 9.04. 
I am able to reproduce the crash on a branch build but not a trunk build (trunk
biuld 2001-08-02-04)

While viewing a bug report, I go to the url and change the bug number, press
Enter, and quickly File|Print and it crashes. 

Incident# 33660599

Stack Trace
0x00000008
VIEW_DLL + 0x5ef4 (0x0bf188d4)
VIEW_DLL + 0x1450 (0x0bf13e30)
VIEW_DLL + 0x13bd4 (0x0bf265b4)
nsListControlFrame::SyncViewWithFrame() [nsListControlFrame.cpp, line 3066]
nsListControlFrame::DidReflow() [nsListControlFrame.cpp, line 3181]
nsContainerFrame::FinishReflowChild() [nsContainerFrame.cpp, line 858]
nsComboboxControlFrame::ReflowComboChildFrame() [nsComboboxControlFrame.cpp,
line 717]
nsComboboxControlFrame::Reflow() [nsComboboxControlFrame.cpp, line 1501]
nsLineLayout::ReflowFrame() [nsLineLayout.cpp, line 962] 
You need to log in before you can comment on or make changes to this bug.